Problem ablout jetson nano Qt -creator debug

I installed Qt with: (Sudo Apt-get Install QT5-Default QtCreator -y) in Jetson Nano and set up the following project。
The following is the file of qt_demo.pro :
//======== This is automatically configured for new projects
QT -= gui
CONFIG += c++11 console
CONFIG -= app_bundle
DEFINES += QT_DEPRECATED_WARNINGS
SOURCES += main.cpp
//========

The following is the file of qt_demo.main.cpp:
//========
#include <QCoreApplication>
#include <QtDebug>
int main(int argc, char **argv)
{
QCoreApplication a(argc, argv);
int c = 10;
qDebug() << c;
return a.exec();
}
//========

And then I can run by ctrl+rI can press CTRL + R to work properly
But I couldn’t debug and got the following error


and I’m using the GDB debugger, as shown below
//=========
GNU gdb (Ubuntu 8.1-0ubuntu3.2) 8.1.0.20180409-git
Copyright © 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type “show copying”
and “show warranty” for details.
This GDB was configured as “aarch64-linux-gnu”.
Type “show configuration” for configuration details.
For bug reporting instructions, please see:
http://www.gnu.org/software/gdb/bugs/.
Find the GDB manual and other documentation resources online at:
http://www.gnu.org/software/gdb/documentation/.
For help, type “help”.
Type “apropos word” to search for commands related to “word”.
//=========

Thank you very much for your help

Hi,
Qt is 3rdparty software implementation and we don’t have much experience on it. What we have tried is to build and install it. The steps are shared in

We don’t have experience on using the debug tool. May need other users to give suggestion.

Thanks for your reply. I recently solved this problem by replacing the QT debugger with an LDB debugger. I wish you every success in your work.