I find it hard to work with Particle Sets

I don’t know the name of the person who created all 20+ physics demo videos this week, but he released almost 2 dozen videos and they helped. The one that helped the most was the applying Particle IsoSurface (a cool feature).

I tried to recreate the Paint Ball demo, however this is what happens to me.


Here is my problem. Any tips are welcome:

I create a sphere. Create a particle sampler. This creates a particle system and a particle set. All is good here. I can apply materials as needed.

The problem is when I create a second sphere, and add Particle Sampler to the 2nd sphere. The 2nd sphere is automatically added to the first particle set.

I would prefer this not be the behavior or I would like to know how to remove the connection. I want to add a different material to the second particle set, and the two spheres seem joined somehow.

I have tried duplicating the particle set, and then I can delete and add targets to assign the second sphere to the 2nd particle set, but the sphere seems joined to the first sphere somehow.

Duplicating the 2nd particle set looks just like the first one. Both spheres are in it:

Basically, how do I create a second particle set for a sphere and create a second material for it?

Thank you

Hi @DataJuggler ,
We don’t like the workflow either, and we will look into making it more explicit in the future. I think the path you took sounds like the right way to go right now, and I quickly tried it again and it works for me. There are some bugs that make this cumbersome that we need to look into, but basically:

  • Create Sphere Mesh “Sphere”
  • Duplicate “Sphere” → “Sphere_01”
  • Add Physics->Particle Sampler to “Sphere”. This creates “ParticleSystem” and “ParticleSet”
  • Duplicate “ParticleSet” → “ParticleSet_01”
  • Add Physics->Particle Sampler to “Sphere_01”, this assigns “ParticleSet” to the new sampler.
  • Select “ParticleSet_01” and remove target, then add “ParticleSet_01” as target.

This works for me, although if I change then “ParticleSet_01” to not being a Fluid, it doesn’t automatically resample, as it should, but it does it when I hit play.

Which version are you on, and what did you mean by “but the sphere seems joined to the first sphere somehow.”

By all means I know the workflow is suboptimal, and there are bugs, but I hope there are ways to work around until we can fix this.

I could have sworn I tried the steps you recommended, but I may have done something wrong. I am using latest Create (2022.3.3).

What I meant by joined is if I select either particle set, both spheres were selected in both particle sets. I may have duplicated at the wrong time. I will try again this weekend when I get some time.

Thank you for the reply, I will try again soon and post the results.


I got it working following your instructions. I had missed the part about changing the Particle Set on the sphere.

It might make it a little simpler if the UI for applying Particle Sampler let you choose to apply to an existing Particle Sampler or to new Particle Sampler / Particle Set.