I2cdetect fails when i2c device is tested on Jetson Nano

Hi ,

I have connected MLX90640 IR sensor to i2c1 bus of Jetson nano. But its not detected most of the times. The detection ratio is like 1 out of 25 times. I have probed the i2c lines while using “i2cdetect -y -r 1” command to detect the MLX90640 device on i2c bus, but i found that SCL is pulling low & not releasing at all.

image

Initially without any operation on the i2c bus, both SDA & SCL is with 3.3 v.
Any operation on the i2c bus makes the clock signal low & never released.
Added 2.4k pullup resistor on MLX90640. But the issue is still not solved.
Tested some other I2C device (Potentiometer ) on jetson nano & its detected successfully.
Tested MLX90640 on beaglebone & its detected

hello karthik.rao,

it usually power issues to caused i2c communication failed, please review your regulator settings.
thanks

Hi JerryChang,

It is true that the I2C communication failed due to power issues. The issue has been resolved. Thankyou for your kind response.