Impossibility of flashing xavier nx on jnx30D

hello, i am working on an Auvidea jnx30D with a Xavier nx(v1) with a previous installation that was wrong(i think a wrong firmware has been installed), so i can’t access the devices because it stops during the boot(device manager fails). i tried to flash using the instructions provided by auvidea( ), but i obtain an error “CPU Bootloader is not running on device.”, then the installation stops. i’m using a pc with ubuntu 18. i tried to force the recovery mode connecting the pin 7 to the ground but i couldn’t obtain any result. i don’t know this kind of device, so i need to understand if i’m acting wrong. i tried also using sdkmanager, but it asks me for username and password that i don’t have, and i have a doubt aout the correct version of the firmware(auvidea suggest the 4.6). i tried to reset the device to fabric state but i haven’t found any information. can you give me some ideas please?

Hi kmgr,

It looks like that you are using a custom board from Auvidea.
Please make sure the board is in Force Recovery Mode
To Determine Whether the Developer Kit Is in Force Recovery Mode

then refer to the flash procedure
To Flash the Jetson Developer Kit Operating Software

hi KevinFFF, i’m using a custom board and i’m using the manual provided by the manifacturer to install the firmware. The problem is that a wrong firmware has been installed, and i’m not able to flash again the device. the board is in recovery mode according to the indication, but i tried also to use pins to put the hardware in the recovery mode manually. it doesn’t work. i have no idea of the problem.
i have a series of error like

Boot Rom communication
[ 5.5159 ] tegrarcm_v2 --chip 0x18 0 --rcm rcm_list_signed.xml
[ 5.5186 ] BootRom is not running
[ 10.6878 ]
[ 11.6939 ] tegrarcm_v2 --isapplet
[ 1022.3957 ]
[ 1022.4009 ] tegradevflash_v2 --iscpubl
[ 1022.4037 ] CPU Bootloader is not running on device.
[ 2038.2039 ]
[ 2039.2099 ] tegrarcm_v2 --isapplet
[ 3054.0119 ]
[ 3054.0176 ] tegradevflash_v2 --iscpubl
[ 3054.0205 ] CPU Bootloader is not running on device.

and then

Error: None of the bootloaders are running on device. Check the UART log.

Hi kmgr

There’s a similar thread about “CPU Bootloader is not running on device” issue.
Please refer to it and check if it could help failing with "CPU bootloader is not running on device" message with JetPack 4.2 - #8 by gdavidmac

You might need to do a full flash to re-partition the device.
Or you can provide me your detailed flash steps for further check

hi KevinFFF, i’ve found the post you mentioned but with the rev i obtained the same result. the support of auvidea makes me try with the last version of the Jetpack 5.0.2 downloading from SDK manager and adding the specific firmware of the board. in this way i was able to flash successfully the device, but when the device starts for the firs time take a lot of time to configure Debconf UI. i attach the screenshot of the problem

i have found a topic abou this problem ad i tried to reset, but i have the same problem. i have no idea.

Hi kmgr

  1. Could you help to provide UART log for further check?
    There are 2 ways to get UART log:
    a. use Micro-USB port for console
    b. Press “ctrl +alt +F1 ~F6” switch to console mode

  2. Unplug all USB ports and reset the device

hi, thanks for the answer. i don’t know this kind of device very well, i connected it to the host with microUsb and using minicom i don’t have any device for the ttyUSB. when the device is connected to the host the operating system does not start. how can i check the logs? thanks


Please flash your board again. Also, if your vendor has any special software for jp4, try to flash with jp4 too.

In the first boot of every jetson after flash, it is asking you to configure the user account so that it can continue to boot. However, the desktop GUI fails to launch on your case.

That is what your issue is.

The “Please complete system configuration setup on xxxx” in your screenshot indicates that.

And in case you don’t know, the method you tried to dump log is not what KevinFFF is asking for.

1 Like

ok, i tried to flash using another version of Jetpack, and using autoflash instead of flash. in this case i was able to flash the device and to configure the user account, the language and the time zone. now i reset the device and the boot seems to take a lot of time. now it’s about 10 minutes on “starting update utmp about System runlevel change”. do you know how much time the boot can require? now i’m providing for the serial console. thanks


That sounds abnormal. I think we really need you to dump the serial log.

Please understand that most issues we can deal with here is based on NV devkit. Or issue that could be reproduced on NV devkit. If your issue is on custom board, I would suggest you report to board vendor first.

Maybe they forget to deliver you some software.

hi, i’ve contacted the vendor of the board, but i have the same problems. i provided for a uart connector in order to search for serial logs, and i’ve noticed that i could access the os through ssh, and operate by command line. so i think the GUI doesn’t work correctly. i’ve thought of a screen resolution problem, but i’ve tried also with a gaming monitor with high resolution. i can attach the logs.
the vendor told me that a Gui should be available, but now i’m not sure.

capture.txt (29.7 KB)

Are you using HDMI or DP?

I’m using hdmi

You might want to use ssh and check that the log file shown in:
ls -ltr /var/log/Xorg.*.log | tail -n 1
…is “Xorg.0.log”.

Then use scp to copy that log to your host PC (and then attach the Xorg.0.log, but in some cases it might be Xorg.1.log).

1 Like

Yes, please dump the xorg log here to clarify.

1 Like

hi, ok, i’m attaching the xorg.0.log and xorg.conf file. maybe i have to configure the hdmi device manually? it seems like raspberry(i’m more expert than jetson), but in raspberry case there is raspi-config which permits to configure in an automatic way.
Xorg.0.log (7.3 KB)
xorg.conf (609 Bytes)
thank you for your attention.


I see this error log

[   228.889] (II) LoadModule: "glxserver_nvidia"
[   228.890] (II) Loading /usr/lib/xorg/modules/extensions/
[   228.898] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[   228.898] 	compiled for 4.0.2, module version = 1.0.0
[   228.898] 	Module class: X.Org Server Extension
[   228.898] (II) NVIDIA GLX Module  32.6.1  Release Build  (integ_stage_rel)  (buildbrain@mobile-u64-5496-d7000)  Thu Sep 16 21:03:39 PDT 2021
[   228.899] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[   228.899] (EE) NVIDIA(0): Failing initialization of X screen 0
[   228.899] (II) UnloadModule: "nvidia"

So I try to check your uart log but I notice it is not completed. You dumped the log after it already booted for 20 sec in kernel. Please dump it from the beginning.

ok, these are my uart log, i hope it can be useful.
i’m sorry this is the complete log
COM3port.txt (78.7 KB)


capture.txt (58.9 KB)

hi, i’ve noticed that when i got the last uart log, i had no hdmi cable, so i’m attaching also a new uart log in case of a connected hdmi cable .
COM3port.txt (74.4 KB)