Screen does not turn on after reboot (Xavier agx) black screen

Hi.
When I entered the nvidia-smi command, the file was not found, so I installed the nvidia driver and rebooted it.
I entered the reboot command at Ubuntu Terminal, but the screen went off and didn’t turn on again. I tried unplugging and plugging the power cable and pressing the button, but the power light comes on, but the monitor screen does not come out. The monitor turns on, but the nvidia logo is not visible. It is not a monitor power issue. I researched to solve this problem and found solutions such as blacklisting But how do I enter the command when the screen doesn’t turn on?
In addition, I would like to reset the xavier to the state before Ubuntu was installed. What should I do?

-ubuntu 18.04
-Jetpack 4.5.1

Please share dmesg and xorg.0.log (/var/log/Xorg.0.log) after xavier boots up.

oh, i’m sorry, I don’t know how to meet your needs without the screen on.

Learn to use uart console to check log and use ethernet to transfer file.

dmesg.odt (116.6 KB)
dmesg2.odt (47.3 KB)

Are these the right files?

Is the dmsg2.odt from your host? We don’t need that log. We are not checking issue of your host.

According to your dmesg.odt, it is not a “screen does not turn on” issue. Your device totally not able to boot the OS at all.

Pease try to reflash the board with sdkmanager.

Oh dmesg2 is host dmesg, not xavier, and dmesg is a log of xavier’s errors? To solve this problem, can I reflash like I installed the jetpack in the early days of Xavier?

dmesg is the kernel log.

Currently, your xavier does not have kernel log. Because it dose not boot into kernel at all. What you see in the uart is the bootloader log.

I am not sure how did you flash xavier in your early days. But flash with jetpack is correct.

Aren’t you going to switch to c-type usb, press the recovery button in the middle, press the power button, and release it at the same time? But the screen is still black screen. Sorry, I don’t think I know much about Xavier.

The steps to enter recovery mode are correct. Do you hit any error during flash?

Or you don’t know how to flash?

More precisely, the recovery button is the last one to get released. Not release them at same time.

FYI, you won’t find this on a Jetson (it uses an integrated GPU). This command is only for the discrete PCI GPUs. Were you trying to find this on the host PC or on the Jetson? If Jetson, then you should not use any driver providing nvidia-smi.

    1. Ensure that the developer kit is powered off.
2. Press and hold down the Force Recovery button.
3. Press, then release the Power button.
4. Release the Recovery button.

Isn’t this the way to flash?

  1. Run sdk manager on host pc.
  2. Install the jetpack of sdk manager step by step.
  3. If the refresh stage is in progress, flash it.

Isn’t this the way? I proceeded with this method, but the screen didn’t turn on.

So Jetson doesn’t support the nvidia-smi command? I didn’t know that and tried to fix the error in the nvidia-smi command, and it seems to have occurred after installing it because the nvidia driver installation said it could fix it. Do you know how to verify the version of the nvidia driver without using the nvidia-smi command?

I proceeded with this method, but the screen didn’t turn on.

Is there any log or picture that can tell the status? Do you know whether the flash process is done or not?

These are the steps for flashing the board.

  1. Put board into recovery mode
  2. Run sdk manager on host pc.
  3. Install the jetpack of sdk manager step by step.
  4. Wait for the flash done. or check if any error log.

flash error.odt (905.6 KB)

An error is occurring in the flash. And the same is true of the black screen phenomenon.

The picture says you didn’t put device into recovery mode.

Did you really flash the board before? Do you see “nvidia” on your host “lsusb” list after you put device into recovery mode?

pressed the recovery button, pressed the power button, removed the recovery button, and put it in the recovery mode. And i went into sdk manager and did flash, but as shown in the picture above, flash error occurred. And I checked lsusb in host pc terminal, but nvidia didn’t. Am i doing something wrong?

Yes, you are doing it wrong.

remove the power cable → plug the power cable → press the recovery button → presse the power button → remove the power button → remove the recovery button.

Do them one by one. There are no buttons get released as the same time.

I did it one by one, not at the same time in the order you told us, and the same result came out.
Is it a problem with the xavier connection? My xavier has a c-usb (host pc) and hdmi cable connected to another monitor and a power cable connected to it.