IMX219 camera not detected in Jetpack 5.1.2

Hi, I have installed jetpack 5.1.2 and when I connect my IMX219 camera it does not work. I’ve tried everything, I’ve been dealing with this for more than 8 hours and before recompiling the kernel I wanted to ask the community.

Here are some dmesg logs:

[   17.772976] imx219 9-0010: tegracam sensor driver:imx219_v2.0.6
[   17.788491] imx219 9-0010: imx219_board_setup: error during i2c read probe (-121)
[   17.885949] imx219 9-0010: board setup failed
[   17.935968] imx219: probe of 9-0010 failed with error -121
[   17.944384] imx219 10-0010: tegracam sensor driver:imx219_v2.0.6
[   17.955169] imx219 10-0010: imx219_board_setup: error during i2c read probe (-121)
[   17.968787] imx219 10-0010: board setup failed
[   17.973658] imx219: probe of 10-0010 failed with error -121

Something strange that I saw and I don’t understand why it is not enabled by default.

user@user:~$ zcat /proc/config.gz | grep -i imx219
#CONFIG_VIDEO_IMX219 is not set

Maybe i have to try with another kernel? i have to add some additional parameter in the .config and recompile the kernel? help please

Default image is include it as loadable module don’t need to recompile it.
Looks like it HW problem to communicate with sensor via i2c.


Thank you for your reply @ShaneCCC. So it could be the magic cable that connects the camera to the jetson? i tried another camera and it also gave me the same error… how could i debug at a lower level what could be the problem? maybe it is the i2c connector of the jetson?

here is an image of how it is connected

resolved: it works with another camera! Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.