In Regard to Connecting Intel Reansense D435 to Isaac ROS VSLAM

Dear NVIDIA Team:

I have installed Isaac ROS on my laptop with the followinf specs:

GPU: GTX1060M
CUDA 11.8
CUDNN 8.7
CPU: Intel i7, 7th Gen
OS: Ubuntu 22.04LTS
ROS2: Humble

Do you know how to run the Isaac ROS VIO/VSLAM on a real Intel Realsense D435 camera?

Thanks in advance!

Sincerely,
Tse Lin

Yes! There is a launch file to bring up Realsense and Isaac ROS Visual SLAM here. Also, there is a tutorial for running Isaac ROS Visual SLAM with Isaac ROS Nvblox on a Realsense camera as well here.

Dear Mr. Hemals:

Firstly, thank you for the reply, and sorry Im new to the industry. So, do you mean, after enter the Docker, run the program like this:

In the first terminal:
source /workspaces/isaac_ros-dev/install/setup.bash &&
ros2 launch isaac_ros_visual_slam isaac_ros_visual_slam_realsense.launch.py

In the second terminal:
source /workspaces/isaac_ros-dev/install/setup.bash &&
rviz2 -d src/isaac_ros_visual_slam/isaac_ros_visual_slam/rviz/default.cfg.rviz

And the RVIZ is like:

It’s still not working, what should I do with “[INFO] [1673336257.087291902] [rviz2]: OpenGl version: 4.6 (GLSL 4.6)
[INFO] [1673336257.109646233] [rviz2]: Stereo is NOT SUPPORTED”?

Sincerely,
Tse

Ok, I found the problem, the error was casued by the USB 2.0 cable. I managed to get it running after replacing it with a USB 3.0 cable. However, the software does not produce recognizable trajectory, I just walked arounf my table and the trajectory is like this:
Screenshot from 2023-01-10 14-16-39

Do you know any way to improve it?

Also, it shows the error message “Tracker is lost” the moment the program start up. I have increased the frame rate but it’s still the same even if the camera is holding static.

What should I do with it?

The RVIZ windows says, is it of any concern?

INFO] [1673357375.581338723] [rviz]: Message Filter dropping message: frame ‘camera_infra1_frame’ at time 1673357375.209 for reason ‘discarding message because the queue is full’

Thanks in advance!

From the logs, it appears you’re running on a D415 with a rolling shutter. We have not tested on this configuration yet. The stereo camera image pair may not be time synchronized correctly or they may be significant motion blurring perhaps. If you could send us a small rosbag recording of your sensor we may be able to diagnose better. Could you also try with a D435 if you have one available?

We have pushed some hotfix changes to the isaac_ros_visual_slam.realsense.launch.py file with updated settings to work with the latest version of librealsense which may also help sort out what’s happening here. Could you give it a try with this new launch file here?