Install VisionWorks on docker

Greetings gentlemen,

I have been trying to build a docker container to use it for development on tx2 and I have came cross this docker image
NVIDIA L4T JetPack Docker Image

I have downloaded l4t-jetpack:r35.1.0
And managed to run it, but it is missing VisionWorks needed by my application so how can I install it separately/manually?

Thanks in advance.

For TX2, the JetPack 4.6.4 is the latest version, which contains the VisionWork, and it’s the last version to support Jetson platform.
From JetPack 5.x, there is no VisionWork, which is instead of by VPI.

@kayccc thank you for the quick response.
So this means I will have to ditch this docker image.
Is there any pre-built docker image that supports Jetpack 4.6?

Or do I have to build it from scratch?

Previously I have tried to build a docker container that supports TX2 with cuda and VisionWorks libraries, but I came cross a library that will only be installed with jetpack through SDK manager.
which contains these files

tegra-egl----
|
-----ld.so.conf
-----libEGL_nvidia.so.0
-----libGLESv1_CM_nvidia.so.1
-----libGLESv2_nvidia.so.2 nvidia.json

So if there’s any way to build it or install these deps?

Hi,

No, We start l4t-jetpack from JetPack 5.
But both TX2 and VisionWorks need JetPack 4 to work.

Please use the base image (l4t-base:r32.7.1) instead and run the OTA command:

$ sudo apt update
$ sudo apt install nvidia-jetpack

Thanks

Hi,
I appricate your help,

I have downlaoded and run l4t-base:r32.7.1

but once i try to run the following command to install jetpack it returns the message bellow.

$ sudo apt update
$ sudo apt install nvidia-jetpack

 E: Unable to locate package nvidia-jetpack

am I missing something?

Hi,

Is there any way to create a docker image from a filesystem.img that I have taken from TX2?
from there i think i can slim down the image by removing the unnecessary dependencies.

Hi @AastaLLL ,

Update 1:
I have tried your method but it did not work with me because as i have found the OTA jetpack update and installation is made available from r35.0

So is there any way I can use to install Jetpack on docker image?

Update 2:
I also tried backing up the system image and use it as a base image for my docker container but once i try to run the same applications it troughs an error message that’s why i think about skipping this approach and search for another one.

Thanks in advance.

Hi,

Please also update the source list.

https://docs.nvidia.com/jetson/archives/l4t-archived/l4t-3273/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/updating_jetson_and_host.html#wwpID0E0GL0HA

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.