Installation Error with CUDA toolkit

I met an error when install jetson component with sdkmanager when connect jetson tx2 to host pc. It seems caused by 404 not found issue. How to fix it? Thanks!
Error msg:

23:44:38 INFO: CUDA Toolkit for L4T: 404 Not Found [IP: 91.189.91.39 80]
23:44:38 INFO: CUDA Toolkit for L4T: Ign:19 http://us.archive.ubuntu.com/ubuntu bionic-backports/universe arm64 Packages
23:44:40 INFO: CUDA Toolkit for L4T: Fetched 252 kB in 6s (44.7 kB/s)
23:44:40 INFO: CUDA Toolkit for L4T: Reading package lists…
23:44:40 INFO: CUDA Toolkit for L4T: E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/bionic/main/binary-arm64/Packages 404 Not Found [IP: 91.189.91.39 80]
23:44:40 INFO: CUDA Toolkit for L4T: E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/bionic-updates/main/binary-arm64/Packages 404 Not Found [IP: 91.189.91.39 80]
23:44:40 INFO: CUDA Toolkit for L4T: E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/bionic-backports/main/binary-arm64/Packages 404 Not Found [IP: 91.189.91.39 80]
23:44:40 INFO: CUDA Toolkit for L4T: E: Some index files failed to download. They have been ignored, or old ones used instead.
23:44:40 INFO: CUDA Toolkit for L4T: Unhandled error when running sudo apt-get -y update
23:44:40 INFO: CUDA Toolkit for L4T: [ Package Install Finished with Error ]
23:44:40 INFO: CUDA Toolkit for L4T: [ NV_L4T_CUDA_TARGET_POST_INSTALL_COMP Install took 1m6s ]
23:44:40 ERROR: CUDA Toolkit for L4T: [error]: dpkg install on target failed; [exec_command]: safe_apt_install “sudo dpkg -i /opt/nvidia/deb_repos/cuda-repo-l4t-10-2-local-10.2.89_1.0-1_arm64.deb” 5; sleep 5; ; safe_apt_install "sudo apt-get -y install cuda-toolkit-10-2 " 5; safe_apt_install “sudo apt-get purge -y cuda-repo-l4t-10-2-local-10.2.89” 5; [deb_path]: /home/cjf/Downloads/nvidia/sdkm_downloads/cuda-repo-l4t-10-2-local-10.2.89_1.0-1_arm64.deb
23:44:40 ERROR: CUDA Toolkit for L4T: command terminated with error
23:44:40 SUMMARY: CUDA Toolkit for L4T: Failed to install debian package [target]

Thanks!

I have re flashed the jetson tx2 and try again, the output is similar

00:59:46 INFO: CUDA Toolkit for L4T: Get:52 http://ports.ubuntu.com/ubuntu-ports bionic-backports/universe Translation-en [4,588 B]
00:59:46 INFO: CUDA Toolkit for L4T: Get:53 http://ports.ubuntu.com/ubuntu-ports bionic-backports/universe arm64 DEP-11 Metadata [9,288 B]
00:59:47 INFO: CUDA Toolkit for L4T: Get:54 http://ports.ubuntu.com/ubuntu-ports bionic-backports/universe DEP-11 48x48 Icons [2,809 B]
00:59:47 INFO: CUDA Toolkit for L4T: Get:55 http://ports.ubuntu.com/ubuntu-ports bionic-backports/universe DEP-11 64x64 Icons [3,943 B]
01:00:00 INFO: CUDA Toolkit for L4T: Reading package lists…
01:00:00 INFO: CUDA Toolkit for L4T: W: GPG error: https://repo.download.nvidia.cn/jetson/common r32.4 Release: The following signatures were invalid: BADSIG 0D296FFB880FB004 NVIDIA Corporation
01:00:00 INFO: CUDA Toolkit for L4T: E: The repository ‘https://repo.download.nvidia.com/jetson/common r32.4 Release’ is not signed.
01:00:00 INFO: CUDA Toolkit for L4T: Unhandled error when running sudo apt-get -y update
01:00:00 INFO: CUDA Toolkit for L4T: [ Package Install Finished with Error ]
01:00:00 INFO: CUDA Toolkit for L4T: [ NV_L4T_CUDA_TARGET_POST_INSTALL_COMP Install took 7m20s ]
01:00:00 ERROR: CUDA Toolkit for L4T: [error]: dpkg install on target failed; [exec_command]: safe_apt_install “sudo dpkg -i /opt/nvidia/deb_repos/cuda-repo-l4t-10-2-local-10.2.89_1.0-1_arm64.deb” 5; sleep 5; ; safe_apt_install "sudo apt-get -y install cuda-toolkit-10-2 " 5; safe_apt_install “sudo apt-get purge -y cuda-repo-l4t-10-2-local-10.2.89” 5; [deb_path]: /home/cjf/Downloads/nvidia/sdkm_downloads/cuda-repo-l4t-10-2-local-10.2.89_1.0-1_arm64.deb
01:00:00 ERROR: CUDA Toolkit for L4T: command terminated with error
01:00:00 SUMMARY: CUDA Toolkit for L4T: Failed to install debian package [target]

hi darouwan:
which sdkmanager version you installed? I installed with JP4.4 on TX2, it is OK

Yes, JP4.4, TX2, sdkmanager 1.3.

Today I try again. After I install tensorflow on TX2, the CUDA toolkit is also successful. Very Strange.