Installation of MLNX_OFED_LINUX-4.7-1.0.0.1-rhel7.5-x86_64.iso under Centos 7.5 is requiring a dependency of kernel-devel-3.10.0-957.el7.x86_64 which is later than the Centos 7.5.1804 updated version of kernel-devel-3.10.0-862.14.4.el7.

I’m attempting to install ofed under Centos 7.5.1804.

The update package for that Centos distribution only provides ​kernel-devel-3.10.0-862.14.4.el7 but the MLNX_OFED_LINUX-4.7-1.0.0.1-rhel7.5-x86_64.iso (mlnxofedinstall) tool is requiring a dependency of kernel-devel-3.10.0-957.el7.x86_64 which is from Centos 7.6.1810.

Is it safe to update the kernel-devel to 957?

Or how do I get the mlnxofedinstall script to require the correct dependency?

The installation command in use:

./mlnxofedinstall --without-fw-update --all --force --without-32bit --add-kernel-support

Or is my yum database just fouled up?

​A bit more info… I’m not sure this isn’t on our end.

cat /etc/*-release

shows Centos 7.5.1804 (core)

but “uname -r” reports “3.10.0-957.el7.x86_64”, which is the kernel for 7.6.1810…

The “uname -r” value appears to be what you use in your installation scripts.

It’s all in a docker container here… and I’m not sure of the container’s pedigree.

Something is crossed up.

Lets see…

Using the 7.6 base and update, I did a yum update of the container to 7.6.

Committed container and restarted it.

That corrected the uname and /etc/*-release​ conflict.

I then still had to do the “yum install kernel-devel-3.10.0-957.el7.x86_64”.

The mlnofedinstall script then ran and reported the same error (run the same install again).

Then I tried just committing the container and restarting it again.

Same issue. The ofed complains about the dependency.

Package is already installed and latest version.

“kernel-devel-3.10.0-957.el7.x86_64” which equates to “kernel-devel-3.10.0-957.12.2.el7.x86_64” per yum update.

from the “MLNX_OFED_LINUX-4.7-1.0.0.1-rehl7.6-x86_64.iso”:

./mlnxofedinstall --without-fw-update --all --force --without-32bit --add-kernel-support

/lib/modules/3.10.0-957.el7.x86_64/build/scripts is required to build mlnx-ofa_kernel RPM.

Please install the corresponding kernel-source or kernel-devel RPM.

Error: One of more required packages for installing OFED-internal are missing.

Please install the missing packages using your Linux distribution Package Management tool.

Run:

yum install kernel-devel-3.10.0.957.el7.x86.64

Failed to build MLNX_OFED_LINUX for 3.10.0-957.el7.x86_64

yum install kernel-devel-3.10.0.957.el7.x86.64

Loaded plugins: fastestmirror, ovl

Loading mirror speeds from cached hostfile

Package kernel-devel-3.10.0-957.el7.x86_64 already installed and latest version

Nothing to do

So… I’m stuck again.

except from the the ​"general.log":

check_linux_dependencies: python-devel is required to build ofed-scripts 4.7

/lib/modules/3.10.0-957.el7.x86_64/build/scripts is rquired to build mlnx-ofa_kernal RPM.

Please install the corresponding kernel-source or kernel-devel RPM.

Hello Andrew,

Based on your posts it looks like you need to create a symbolic link in the /lib/modules/3.10.0-957.el7.x86_64/ folder to the relevant folder in /usr/src .You can do this by running:

ln -s /usr/src/kernels/3.10.0-957.el7.x86_64/ /lib/modules3.10.0-957.el7.x86_64/build

Then run the OFED install script as you did in your first post.

Hope this solves your issue and if you have any further questions feel free to open a support ticket with us by emailing support@mellanox.com as you have a valid support contract.

Thanks,

Abigail.

​Failed to build MLNX_OFED_LINUX for 3.10.0-957.el7.x86_64

yum install kernel-devel-3.10.0-957.el7.x86_64

updates

Package kernel-devel-3.10.0-957.el7.x86_64 already installed and latest version

Nothing to do.

Hello Andrew,

Hope you are doing well.

Could you run a few commands for me and post the output here?

  1. rpm -qf /lib/modules/3.10.0-957.el7.x86_64/build/scripts/

  2. ls -al /lib/modules/3.10.0-957.el7.x86_64/

  3. rpm -qf /usr/src/kernels/3.10.0-957.el7.x86_64/scripts/

Thanks,

Abigail.