Installing CUDA Toolkit A matter of life and death

Dear Nvidia!

Recently i decided to pick your product for my Ph.D. graduation project. Having installed my new GTX280, i got the following config: Asus P6T Deluxe, Core i7-920, GTX280, 4Gb RAM, Vista x64 Ultimate, etc.
And everything was done only to discover that i can’t install CUDA Toolkit (of course win64 version)! Installation of v2.1 was going all good (copying) until the InstallShield Window minimized to tray and just stood there completely frozen for more than a couple of hours. Task can’t be closed, only process-killed. Having thought that it might be a version related bug, i DL’ed a v2.0, for the same picture.
It seems to me, that it fail to correctly register in Win-registry. Also uninstall is broken, giving me error -5001. Cycling power doesn’t solve it. Only manual cleaning of registry and InstallShield temp do. But still then, i can’t install ANY version of CUDA Toolkit (SDK installs OK)!!!
P.S. Before installing CUDA Toolkit i did a full install of MS Visual C++ 2008 Express, which updated the Windows Installer to 4.5. Does this matter?

Please help me! My project is totally based on CUDA and is falling apart because of this strange bug!

What about installing everything on Linux?

yeah, has anyone used VC++ 2008 Express successfully yet? I don’t know, it’s not one of our officially supported configurations and I have VS2008 installed everywhere already…

I would probably just use Linux because you can avoid other problems (watchdog timer, ridiculous overhead for CUDA calls).

On one of the older versions (2.0, I think), I tried installing VS2005 C++ Express on my XP x64 box and ran into the same problems. Once I upgraded to Vista x64, CUDA 2.1 and VS2008 Professional, I’ve never had any problems.

So, how do i get rid of this buglike thing other than installing Linux (under consideration,but…)?!
And can one describe in details the normal process of installation of Toolkit, please?
Maybe if it fails only to register, but not copying, i could get it to work just linking the VC 2008 to CUDA’s dirs?

tmurray indicated that the problem may be because Visual Studio 2008 express is not a supported configuration. You should try uninstalling it and running Vc++ 2005 express, which is the only free windows compiler supported by CUDA. If you simply must have VS2008, you can try DreamSpark: https://www.dreamspark.com/default.aspx . Since you are a grad student, you should be able to download the full version of VS2008 from microsoft for free.

However, I will confirm what others have said. Linux is by far the easiest route to go. Download the latest CentOS (equivalent to RHEL). After installing that, you’ll have CUDA up and running in a matter of minutes. It will save you time in the long run too, as there are a number of limitations of CUDA on windows that you will run into which don’t pose a problem in linux.

Just like any other windows installshield program. Open it, click next next next next, it shows a progress bar whiz by and it is done.

I’m using VC++ 2008 express with CUDA without any trouble.

Sounds like you have a corrupted install registry entry - unfortunately, these are really nasty to figure out and fix, it might be simplest to reinstall Windows from scratch and go from there…

I have the same problem here. I doubt it’s a registry problem.

Those people have the same problem too:
http://forums.nvidia.com/index.php?showtopic=88225
http://forums.nvidia.com/index.php?showtopic=77641

All are using 2.1 in a 64bit OS if that matters. I need this working ASAP…

I’m having the same issue with not being able to uninstall the old version of CUDA Toolkit.

I am running Windows XP 32-bit, have both VS 2005 and VS 2008 installed. I need to uninstall the old version of the CUDA Toolkit so I can upgrade to 2.1 to use a Matlab plugin built using it.

Does anyone have a solution to force the uninstall somehow? For me it just hangs.

Thanks

I have same problem, too!! I try to install to my notebook(asus n10j) with geforce9300gt on vista-32bit.
Coud anyone solve ?
Why nVidia takes no account of this problem!! Please support, quickly.

I have the same problem, too !

My machine: ASUS Laptop, 9700 GT(being a poor student ;) ), Vista Ultimate x32 and VS 2008 Pro

I have installed “cudadriver_2.2_vista_32_185.85_notebook.exe” Setup successfully.

But the CUDA-Toolkit-Setup version 2.2 does not run !

When I try to start running the file, nothing happens.

Is there any way to do it better ?

Thank you for any information.

Same problem here. This is a serious issue and hopefully will be addressed soon.

Install Shield hangs indefinitely when installing CUDA Toolkit 2.3 (driver and SDK install fine). After rebooting, the SDK examples crash. It is also not possible to uninstall the CUDA Toolkit in this zombie-like state.

I’m running Vista 64-bit, Core i7-920 with a GTX 285.

If anyone has a workaround, please post.

I figured out how to get the CUDA Toolkit 2.3 to install. This is after the initial hang failure. Once you’ve “installed” the 2.3 toolkit you can no longer uninstall it with InstallShield but you can at least fool it with some registry editing.

Here is the (very ugly) procedure. I’m using 64-bit Vista so you will have to change the directories if you are using the 32-bit version:

First try to uninstall the 2.3 toolkit. This is easier said than done since InstallShield won’t be able to. However, it will present a dialog box with a GUID. Copy the GUID down and search for it in the registry. Delete all values returned in the list in the registry. Delete all of these, as well as deleting the C:\CUDA directory. There were about 10 of these or so if I recall. I could not delete one for some reason, but delete as many as you can (we’re desperate). Reboot.

Uninstall the 2.3 SDK and driver, in that order. Reboot.

Reinstall the CUDA 2.3 drivers, 2.3 toolkit, and SDK in that order. The toolkit install will hang indefinitely but don’t worry…just kill it in the task manager (look for any processes with “cuda” in the name). Reboot.

Now you should verify that the C:\CUDA\bin64 directory has the correct nvcc version (check from the command line with “nvcc --version”). You should see 2.3. You can also check the system information from the NVIDIA Control Panel.

Add C:\CUDA\bin64 to the PATH. The installer will incorrectly add C:\CUDA\bin to your PATH. Note that I am using the Windows SDK 6.1 for my command line compilers and not the Visual C++ tools. I suspect the CUDA installers aren’t tested with command-line only compilers but rely on Visual Studio being present in one form or another. Reboot.

Now launch the SDK browser and the examples will run properly.

I really hope NVIDIA could modify the installers to just rely on installed compilers and not Visual Studio when setting the PATH. There is also a bug in the installer that causes it to hang on the CUDA Toolkit package and requires the process to be killed. Curiously, not everyone is having this problem.

If anyone can improve on this procedure please post your findings.

My question is if we are all having the same problem why is NVIDA not doing something about it. As you can see it is a reaccuring problem over diffrent releases and windows platforms

I get the same error while uninstalling:

[attachment=15310:when_Uni…_Toolkit.jpg]

[attachment=15311:when_Uni…Toolkit2.jpg]

and installing hangs.

Hasn’t this been fixed yet by NVIDIA?
when_Unistalling_NVidia_CUDA_Toolkit2.jpg
when_Unistalling_NVidia_CUDA_Toolkit.jpg