installing driver 367.57 on dual monitor

Hello!
I have a new pc with Intel I7 processor, motherboard Asus H110-plus, 16 GB RAM and, finally, a video card Nvidia GTX 950 (in dual monitor setup). My monitor are 2 samsung 16:9 working at 1360x768 resolution both.
The pc is provided by Xubuntu 16.04 and KDE neon 5.8.90.
I have tried to installing the latest Nvidia driver (367.57) from Additional drivers and it goes well but, after reboot, only the main monitor works well.
Why the secondary monitor is black after reboot?
At this moment I’m using open source driver and the monitors work fine. The main monitor works through DVI-I and the secondary monitor works with HDMI-I.
I will appreciate any comment to this my message, thanks!

I had to update firmware as well. I have the same setup and it works.

https://01.org/linuxgraphics/intel-linux-graphics-firmwares

Many thanks coremans.
Could you, or someone else, explain the way to resolve? (All passages, please…).
Remeber all: I am not so good in English, sorry.
I have read in the link posted by coremans (the Intel page) that lowlatency kernel is not supported by this update…I have on my pc lowlatency kernel just for play a MIDI keyboard.

First, did you install via

sudo apt-get install nvidia-367

?

No, I have installed from Additional drivers.

try from CLI and see if you get a message that saya you have to update the firmware as well.

sorry, what is CLI?

marco@PC:~$ uname -a
Linux PC 4.4.14-040414-lowlatency #201606241434 SMP PREEMPT Fri Jun 24 18:41:30 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
marco@PC:~$

CLI = Command Line Interface (so from the terminal)

You can also try:

sudo apt-get install nvidia-375

which is a beta driver, better suitable for the 1050 card

marco@PC:~$ sudo lshw -c video
[sudo] password di marco: 
  *-display               
       description: VGA compatible controller
       product: GM206 [GeForce GTX 950]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:124 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
marco@PC:~$

and

marco@PC:~$ sudo ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
vendor   : NVIDIA Corporation
modalias : pci:v000010DEd00001402sv00001043sd000085B2bc03sc00i00
model    : GM206 [GeForce GTX 950]
driver   : xserver-xorg-video-nouveau - distro free builtin
driver   : nvidia-367 - distro non-free recommended

== cpu-microcode.py ==
driver   : intel-microcode - distro non-free

marco@PC:~$

That looks good. I don`t see any issue here.
But the second monitor still does not work ?

Check what your nvidia X server settings show:

sudo nvidia-settings

You will see the dual display config there.

I have just updated with “sudo apt-get install nvidia-367” but now only the main monitor in working in a wrong resolution (1024x768) instead of 1360x768. Any ideas?

marco@PC:~$ sudo nvidia-settings
** Message: PRIME: No offloading required. Abort
** Message: PRIME: is it supported? no

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

marco@PC:~$

also after reboot ?

Did you check sudo nvidia-settings

with the 367 driver:

marco@PC:~$ sudo lshw -c video
[sudo] password di marco: 
  *-display               
       description: VGA compatible controller
       product: GM206 [GeForce GTX 950]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
marco@PC:~$

is it ok?

here the lastest updates:

marco@PC:~$ sudo apt install nvidia-367
[sudo] password di marco: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
nvidia-367 is already the newest version (367.57-0ubuntu0.16.04.1).
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
marco@PC:~$ sudo lshw -c display | grep driver
       configuration: driver=nouveau latency=0
marco@PC:~$

It seems that the nvidia-367 is installed but why, in the second command, is indicated the nouveau? Anyway now, after disinstalling lowlatency kernel, the monitors works fine both.

You should not have both the nouveau and the nvidia driver installed.
If you want to use the nvidia driver, you probably need to disable the nouveau driver. Look at
http://us.download.nvidia.com/XFree86/Linux-x86_64/367.57/README/commonproblems.html
There is a section (8.1) about disabling the nouveau driver.

Hi, the installation notes in the Getting Started guide for Linux outlines what you need to do.

First from what you have shown, you have both nouveau and nvidia installed.

Check the following:

  1. nvidia-smi = See what this report, it should report 367.57
    Example:

nvidia-­smi

+­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­+

| NVIDIA­SMI 352.30 Driver Version: 352.30 |

|­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­+­­­­­­­­­­­­­­­­­­­­­­+­­­­­­­­­­­­­­­­­­­­­­+

| GPU Name Persistence­M| Bus­Id Disp.A | Volatile Uncorr. ECC |

| Fan Temp Perf Pwr:Usage/Cap| Memory­Usage | GPU­Util Compute M. |

|============+======================+======================|

| 0 GeForce GTX 960 Off | 0000:01:00.0 On | N/A |

| 0% 28C P8 7W / 128W | 216MiB / 4091MiB | 0% Default |

+­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­+­­­­­­­­­­­­­­­­­­­­­­+­­­­­­­­­­­­­­­­­­­­­­+

| 1 GeForce GT 730 Off | 0000:02:00.0 N/A | N/A |

| 30% 28C P8 N/A / N/A | 66MiB / 1023MiB | N/A Default |

+­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­­+­­­­­­­­­­­­­­­­­­­­­­+­­­­­­­­­­­­­­­­­­­­­­+

If this does not show any information then use below:
Verify what is in proc, lsmod, dmesg messages

cat /proc/driver/nvidia/version

This should report the same 367.57 driver

  1. Create the following file in /etc/modules.d

Created blacklist entry, /etc/modprobe.d/blacklist­nouveau.conf as shown below

cat /etc/modprobe.d/blacklist­nouveau.conf

blacklist nouveau
options nouveau modeset=0

  1. kernel option used, nomodeset
  2. Used Nvidia xconfig tool, nvidia­xconfig

Please review the installation guide, Chapter 4 - Linux (this info is the same for all CUDA releases since 4.0)…
https://developer.nvidia.com/compute/cuda/8.0/prod/docs/sidebar/CUDA_Quick_Start_Guide-pdf

What is being stated is correct!
My favor of Linux installed the 357.30 driver. I had to go into single user maint. mode (execute: init 1)

  1. Execute: init 1
    1a. lsmod | grep nouveau
    1b. lsmod | grep -i nvidia
    1c. If there exist nouveau, then ‘rmmod nouveau’
  2. Previous (downloaded the nvidia driver, 367.57)
    execute ./NVIDIA_…run
  3. Verified that /etc/modules.d/ has a blacklist entry as noted in Chapter 4 of Getting Started Guide
  4. Saved a copy of the Xorg.conf file by: cp /etc/X11/xorg.conf /etc/X11/xorg-nv.conf
    Executed: nvidia-xconfig
  5. Rebooted: systemctl reboot (or just reboot)

Post your xorg.conf file
I will share what I have, I am using two monitors with two different resolutions.

Thanks to all answers.
After disinstalling nouveau everything has gone OK. I’ve resolved!