Installing local .deb file for cuda-toolkit 11.7.1 installs cuda toolkit 12.0

I am trying to install cuda toolkit 11.7.1 with NVIDIA driver 515.65.01 for DeepStream 6.1.1 in my Ubuntu 20.04 machine. I am following the steps given for local .deb installation of the cuda toolkit. Everything goes well until I run the last instruction. Running the last instruction sudo apt-get -y install cuda starts installing cuda toolkit 12.0 with 525.60.13 NVIDIA drivers which is not desired. Changing the command to sudo apt-get -y install cuda-toolkit-11-7 installs 11.7 version but I want 11.7.1 and sudo apt-get -y install cuda-toolkit-11-7-1 doesn’t work. I tried installing cuda toolkit 11.7.1 using local runfile but the installation fails with no specific error found in /var/log/cuda-installer.log.

Is there something I am missing or overlooked?
I sincerely request you to help me install cuda toolkit 11.7.1 with NVIDIA driver 515.65.01.
Thanking you in advance

1 Like

Thank you for your response!
I tried running the command given in the documentation of the page sudo apt-get install cuda-11-7.
Eventually, it installed cuda 12.0 with NVIDIA driver version 525.60.13.
However, DeepStream 6.1.1 expects cuda toolkit 11.7.1 with NVIDIA driver 515.65.01.
My problem still persists.