Installing Nemo failed with error ModuleNotFoundError: No module named 'Cython' even though Cython is installed

Hello,

I tried to install Nemo Toolkit on my Jetson Nano following the guide at Pip from Source Introduction — NVIDIA NeMo

But getting the error “ModuleNotFoundError: No module named ‘Cython’” even though Cython is installed.

Installation of the Nemo:

apt-get update && apt-get install -y libsndfile1 ffmpeg
pip install Cython
python -m pip install git+https://github.com/NVIDIA/NeMo.git@{BRANCH}#egg=nemo_toolkit[all]

Everything is running in a docker container, base image 4t-ml:r32.7.1-py3. And Python 3.9.

I attached the outputs and screenshots in this message.

Is the error simply because Jetson Nano is not support? I tried to install Nemo on another computer with Python 3.11, Cython installed, and received the same exact error. I need another set of eyes.

I appreciate your support and guidance.

Many thanks,
-Vi





Issue Resolved! Thank you!

Would you mind to share how your issue resolved? Thanks

The stack trace shows the build for youtokentome failed. A search for youtokentome and Cython took me to this GitHub discussion:
NeMo installation fails due to outdated abandoned dependency on youtokentome · Issue #6854 · NVIDIA/NeMo (github.com)

The fix is to build and install youtokentome before Nemo toolkit with:
pip install “git+https://github.com/LahiLuk/YouTokenToMe”

Great! Thanks for your sharing!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.