Installing VisionWorks 1.6 failed in JetPack 3.2.1

Hi folks,

I got this error while I am installing JetPack 3.2.1

**Installing VisionWorks 1.6 failed.

Return Code: 1
Error installing libvisionworks libvisionworks-dev libvisionworks-samples to host, please check /home/mohammed/Desktop/JetPack3-2/_installer/logs/visionworks_host.log for more details **

what I have done is:

1- I run JetPack-L4T-3.2.1-linux-x64_b23.run
2- The installation starts and I chose full installation
3- it downloads and install but while installing VisionWorks it get this error message

and here is the mentioned file (visionworks_host.log) contents

Selecting previously unselected package libvisionworks-repo.
(Reading database … 364778 files and directories currently installed.)
Preparing to unpack …/libvisionworks-repo_1.6.0.500n_amd64.deb …
Unpacking libvisionworks-repo (1.6.0.500n) …
Setting up libvisionworks-repo (1.6.0.500n) …
OK
Get:1 file:/var/cuda-repo-9-0-local InRelease
Ign:1 file:/var/cuda-repo-9-0-local InRelease
Get:2 file:/var/visionworks-repo InRelease
Ign:2 file:/var/visionworks-repo InRelease
Get:3 file:/var/cuda-repo-9-0-local Release [574 B]
Get:4 file:/var/visionworks-repo Release [1,999 B]
Get:3 file:/var/cuda-repo-9-0-local Release [574 B]
Get:4 file:/var/visionworks-repo Release [1,999 B]
Get:5 file:/var/visionworks-repo Release.gpg [819 B]
Get:5 file:/var/visionworks-repo Release.gpg [819 B]
Ign:8 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:9 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial InRelease
Hit:10 http://eg.archive.ubuntu.com/ubuntu xenial InRelease
Get:7 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]
Hit:11 http://dl.google.com/linux/chrome/deb stable Release
Hit:14 http://ppa.launchpad.net/umang/indicator-stickynotes/ubuntu xenial InRelease
Hit:15 http://packages.ros.org/ros/ubuntu xenial InRelease
Get:16 http://eg.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Hit:17 https://packages.microsoft.com/repos/vscode stable InRelease
Get:18 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [819 kB]
Ign:19 http://eg.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:20 http://eg.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:21 http://eg.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Get:22 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [637 kB]
Ign:23 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages
Get:24 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [479 kB]
Get:25 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [413 kB]
Ign:26 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages
Ign:27 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages
Get:12 http://eg.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Ign:23 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages
Ign:26 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages
Ign:19 http://eg.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:20 http://eg.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:27 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages
Ign:21 http://eg.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Ign:28 http://eg.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
Ign:29 http://eg.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Ign:19 http://eg.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:23 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages
Ign:26 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages
Ign:27 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages
Err:23 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages
404 Not Found [IP: 91.189.88.162 80]
Ign:20 http://eg.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Get:30 http://eg.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [1,099 kB]
Get:31 http://eg.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [897 kB]
Ign:32 http://eg.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
Ign:26 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages
Get:33 http://eg.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [783 kB]
Get:34 http://eg.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [711 kB]
Ign:35 http://eg.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Ign:36 http://eg.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Ign:27 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages
Ign:21 http://eg.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Ign:28 http://eg.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
Ign:29 http://eg.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Err:19 http://eg.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
404 Not Found [IP: 91.189.91.24 80]
Ign:20 http://eg.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:32 http://eg.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
Ign:35 http://eg.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Ign:36 http://eg.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Ign:21 http://eg.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Ign:28 http://eg.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
Ign:29 http://eg.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Ign:32 http://eg.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
Ign:35 http://eg.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Ign:36 http://eg.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Err:28 http://eg.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
404 Not Found [IP: 91.189.91.24 80]
Ign:29 http://eg.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Err:32 http://eg.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
404 Not Found [IP: 91.189.91.24 80]
Ign:35 http://eg.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Ign:36 http://eg.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Fetched 325 kB in 6s (52.4 kB/s)
Reading package lists…
E: Failed to fetch http://eg.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-arm64/Packages 404 Not Found [IP: 91.189.91.24 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-arm64/Packages 404 Not Found [IP: 91.189.88.162 80]
E: Failed to fetch http://eg.archive.ubuntu.com/ubuntu/dists/xenial-backports/main/binary-arm64/Packages 404 Not Found [IP: 91.189.91.24 80]
E: Failed to fetch http://eg.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/binary-arm64/Packages 404 Not Found [IP: 91.189.91.24 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists…
Building dependency tree…
Reading state information…
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libvisionworks : Depends: cuda-cudart-10-0 but it is not installable
libvisionworks-samples : Depends: cuda-cudart-dev-10-0 but it is not installable or
nvidia-cuda-dev (>= 10.0) but it is not going to be installed
Recommends: cuda-npp-dev-10-0 but it is not installable or
nvidia-cuda-dev (>= 10.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi,

Based on the log, it seems that you are installing CUDA 9.0 and VisionWorks 1.6 which requires CUDA 10.0 at the same time.

If you want to use the VisionWorks, please install the package provided from the JetPack3.2.1.
Thanks.

Hi,

I don’t know why this versions conflict happened. But I just downloaded the jetpack 3.2.1 release and make it executable and then run it with full install and it got me this error. Should I make anything more than what I did in the installation part?
Thank you

Hi,

Do you have any dependency on the JetPack3.2.1?

We have verified that VisionWorks installation on our latest release.
Would you mind to get our latest JetPack a try?

Thanks.