bug - installing JetPack 3.1

Using the same Ubuntu 16.04 desktop that I installed JetPack 3.0 on, which installed without any problems. When I try to install 3.1, it hangs at installing VisionWorks and will not go any further. Error message is error code 1.

tail of visionworks_host.log shows (and I don’t know what that reference to security.xenail… is about):

404  Not Found [IP: 91.189.88.162 80]
Ign:71 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages
Fetched 1,428 kB in 3s (377 kB/s)
Reading package lists...
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_libopencv4tegra-repo_Release
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-arm64/Packages  404  Not Found [IP: 91.189.91.26 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/binary-arm64/Packages  404  Not Found [IP: 91.189.91.26 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-backports/main/binary-arm64/Packages  404  Not Found [IP: 91.189.91.26 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-arm64/Packages  404  Not Found [IP: 91.189.88.162 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  autotools-dev debhelper dh-strip-nondeterminism gstreamer1.0-libav
  gstreamer1.0-plugins-bad-videoparsers icu-devtools libavfilter-ffmpeg5
  libbs2b0 libeigen3-dev libfile-stripnondeterminism-perl libflite1
  libfreetype6-dev libglib2.0-dev libgstreamer-plugins-bad1.0-0
  libgstreamer-plugins-base1.0-dev libgstreamer1.0-dev libicu-dev
  libmail-sendmail-perl libpcre3-dev libpcre32-3 libpcrecpp0v5 libpng12-dev
  libsodium18 libsys-hostname-long-perl libxml2-dev libzmq5 po-debconf
Suggested packages:
  dh-make libeigen3-doc libmrpt-dev libglib2.0-doc gstreamer1.0-doc icu-doc
  libmail-box-perl
The following NEW packages will be installed:
  autotools-dev debhelper dh-strip-nondeterminism gstreamer1.0-libav
  gstreamer1.0-plugins-bad-videoparsers icu-devtools libavfilter-ffmpeg5
  libbs2b0 libeigen3-dev libfile-stripnondeterminism-perl libflite1
  libfreetype6-dev libglib2.0-dev libgstreamer-plugins-bad1.0-0
  libgstreamer-plugins-base1.0-dev libgstreamer1.0-dev libicu-dev
  libmail-sendmail-perl libpcre3-dev libpcre32-3 libpcrecpp0v5 libpng12-dev
  libsodium18 libsys-hostname-long-perl libvisionworks libvisionworks-dev
  libvisionworks-docs libvisionworks-samples libxml2-dev libzmq5 po-debconf
0 upgraded, 31 newly installed, 0 to remove and 0 not upgraded.
Need to get 955 kB/95.8 MB of archives.
After this operation, 255 MB of additional disk space will be used.
Err:1 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libfreetype6-dev amd64 2.6.1-0.1ubuntu2.2
  404  Not Found [IP: 91.189.91.23 80]
Get:2 file:/var/visionworks-repo  libvisionworks 1.6.0.193n [8,847 kB]
Get:3 file:/var/visionworks-repo  libvisionworks-dev 1.6.0.193n [144 kB]
Get:4 file:/var/visionworks-repo  libvisionworks-docs 1.6.0.193n [4,128 kB]
Err:1 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libfreetype6-dev amd64 2.6.1-0.1ubuntu2.2
  404  Not Found [IP: 91.189.91.23 80]
Get:5 file:/var/visionworks-repo  libvisionworks-samples 1.6.0.193n [53.5 MB]
W: --force-yes is deprecated, use one of the options starting with --allow instead.
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/f/freetype/libfreetype6-dev_2.6.1-0.1ubuntu2.2_amd64.deb  404  Not Found [IP: 91.189.91.23 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Hi,

Is your host Ubuntu16.04?

My environment is an Ubuntu 16.04 desktop that previously loaded 3.0 successfully.

Hi,

JetPack doesn’t support Ubuntu16.04; Please switch to Ubuntu14.04 to make it work.

Guess that you need to fix this to make VWs installed on xenial:

Err:1 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libfreetype6-dev amd64 2.6.1-0.1ubuntu2.2
404 Not Found [IP: 91.189.91.23 80]

We have well tested JetPack3.1 on Ubuntu14.04. Please try to install it on 14.04.
Thanks and sorry for the inconvenience.

Go back generations prior to this old generation, 16.04? I’ve got too much software and time involved in this 16.04 – which I didn’t even want but only installed because y’all said it was needed for the TX2.

PLEASE buy back my TX2. I’ll find another platform for collision avoidance on my drone.

JetPack 3.0 has problems. Now, 3.1 is supposed to fix 3.0 but has even MORE problems than 3.0.

Hi AastaLLL,

How can I upgrade JetPack 3.1 into JetPack 3.1?

Thanks.

FYI, command line flash has no dependency on an Ubuntu host…it works from any x86_64 Linux PC (uses driver package plus sample rootfs).

Hi Skypuppy2,

This issue is from libfreetype6-dev not available on xenial.
Guess that JetPack3.0 will also meet the same error currently.

Maybe can try this?
https://launchpad.net/~ubuntu-security/+archive/ubuntu/ppa/+build/12450911

I will feedback this issue internally.
Sorry for the inconvenience.

Hi zimenglan,

JetPack 3.1 is available here:
https://developer.nvidia.com/embedded/jetpack

Thanks, but I am burnt out on trying to solve all the MINOR problems that prevent me from using this $600 product, the TX2. I’d be happy if nVidia will just buy it back. Several months time, and so many man-hours wasted fiddling with this non-standard unit that I had such high hopes for. I’m done.

Plus, having to “reset my password” every time I login, makes me really wonder about nVidia’s overall quality.

And btw, my recommendations carry significant weight with hundreds of units to be purchased, like the US Army…

1 Like

Hi AastaLLL,

I have installed JetPack 3.0 and JetPack 3.1 in my TX2, but the default is JetPack 3.0, I don’t know how to remove JetPack 3.0 or set JetPack 3.1 as default.

Thanks.

Hi Skypuppy2,

We have checked VisionWorks host on Ubuntu16.04 PC and can install the package without error.
Could you try apt-get update and install VWs again?

Thanks.

AastaLLL,

Yep, tried your suggestion and did it again this morning. Neither apt nor apt-get showed any updates available, so everything from Ubuntu 16.04.2 is current. note: when I first got the TX2, I tried Ubuntu 17 latest and greatest. But JetPack 3.0 completely broke in 17, so that time was wasted. Then I saw the fine print that you wanted 14 or 16, so I tried 16.04 and 3.0 loaded just fine. 3.1, not so much.

Started 3.1 install again, and while it did download and install some of the new packages prior to VisionWorks, it died on VisionWorks (VW) with the exact same error message and nothing below it could be gotten to in the script, and I’m not sure how your script package interdependencies are written so I can’t comment out just the VW package so everything can try to install.

Please buy back the TX2.

David

Hi David,

We are sorry for the inconvenience.
Could you the following command and re-install it again?

[i]After flashing the device using Ubuntu 16.04 on the host machine and rebooting, unable to install software applications from the Ubuntu Application Center.
To workaround:
Change the group ownership from lighdm to messagebus for the following file:

/usr/lib/dbus-1.0/dbus-daemon-launch-helper[c/ode]
The commands are as follows:
[code]$ ls -l /usr/lib/dbus-1.0/dbus-daemon-launch-helper
-rwsr-xr-- 1 root lightdm 38824 Jul 12 18:17 /usr/lib/dbus-1.0/dbus-daemon-launch-helper
sudo chown root:messagebus /usr/lib/dbus-1.0/dbus-daemonlaunch-helper
sudo chmod 4754 /usr/lib/dbus-1.0/dbus-daemon-launch-helper

Note: NVIDIA supports Ubuntu 14.04 as the host operating system.[/i]

This information is from our release note, issue 200276225.

The Problem is, that libfreetype6 2.6.1-0.1ubuntu2.2 is neither included in 14.04 nor 16.04.

Read here:
https://packages.ubuntu.com/search?keywords=ibfreetype6-dev&searchon=names

14.04 is 2.5.2-1ubuntu2.8 [security]: amd64 i386
and 16.04 is 2.6.1-0.1ubuntu2.3 [security]: amd64 i386

I am not sure which version is really need for 14.04 because I only tried 16. While I was searching for the correct version I found one link to a launchpad site with the right version provided as debfile. I am not sure if I am allowed to provide it here but it can easily be found.

After installing that manually, visionworks installed and works for me.

Hi lassebk,

Thanks for updating this information.
We will feedback to the internal team.

Thanks.