Is it possible to install TensorRT 7.2.2 on Ubuntu 20.04?

Description

How can I fix this issue?

E: Unable to correct problems, you have held broken packages.

Environment

TensorRT Version: 7.2.2
GPU Type: RTX 2060
Nvidia Driver Version: 455.45.01
CUDA Version: 11.1
CUDNN Version: 8.0.5
Operating System + Version: Ubuntu 20.04
Python Version (if applicable): 3.7.9
TensorFlow Version (if applicable): not used
PyTorch Version (if applicable): 1.7.1
Baremetal or Container (if container which image + tag): not used

Relevant Files

Error log

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tensorrt : Depends: libnvinfer7 (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvinfer-plugin7 (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvparsers7 (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvonnxparsers7 (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvinfer-bin (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvinfer-dev (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvinfer-plugin-dev (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvparsers-dev (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvonnxparsers-dev (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvinfer-samples (= 7.2.2-1+cuda11.1) but it is not going to be installed
            Depends: libnvinfer-doc (= 7.2.2-1+cuda11.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

1 Like

Hi @1chimaruGin,
I am afraid but currently TRT supports till Ubuntu 18.04.
Support for next versions will be added in future releases.

For other supported versions please follow the steps mentioned in the installation guide.

Thanks!

1 Like

Oops! I got that error because I wrongly deleted key in /var/cuda-repo-ubuntu2004-11-1-local/7fa2af80.pub. Now, I can install TRT.

1 Like

That’s very very bad, that nvidia supports outdated platforms, only. Ubuntu 20.04 is almost 1 year out there and at least +0.5 year where it got prepared for release and still no packages available. Shame on you!

7 Likes

Hi, Do you install tensorRT in ubuntu20.04?

1 Like