[Isaac 2022.2.0] set_camera_view seems broken

The function set_camera_view docu seems broken in the new release

The view jumps to some random large scale values.
image

Hi there,

could you send the steps or the script to reproduce the issue?

Best,
Andrei

I found out that this behavior happens when the camera is pointing directly to the ground.

Example (for streaming, as I use remote machine):

from omni.isaac.kit import SimulationApp

simulation_app = SimulationApp({"headless": True})

from omni.isaac.core.utils.extensions import enable_extension
# Default Livestream settings
simulation_app.set_setting("/app/window/drawMouse", True)
simulation_app.set_setting("/app/livestream/proto", "ws")
simulation_app.set_setting("/app/livestream/websocket/framerate_limit", 120)
simulation_app.set_setting("/ngx/enabled", False)

# Note: Only one livestream extension can be enabled at a time
# Enable Native Livestream extension
# Default App: Streaming Client from the Omniverse Launcher
enable_extension("omni.kit.livestream.native")

from omni.isaac.core import World
from omni.isaac.core.utils.viewports import set_camera_view
import numpy as np
from omni.isaac.core.objects.ground_plane import GroundPlane


my_world = World(stage_units_in_meters=1.0)
GroundPlane(prim_path="/World/groundPlane", size=10, color=np.array([0.5, 0.5, 0.5]))
set_camera_view(eye=np.array([1, 1, 1]), target=np.array([1, 1, 0.5]))
while simulation_app.is_running():
    my_world.step(render=True)

simulation_app.close()

If I set target=np.array(1, 1.5, 0.5) the camera params are fine again and it is looking to the ground.

Thanks, I can confirm the bug, as a temporary workaround you can use a value such as [1, 1.000001, 0.5]when looking on the Z axis.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.