Issue with CSI Camera Testing on Jetson Nano - Seeking Assistance

hello 901026ben,

it looks something wrong for sending MIPI signal.
since it’s NOT a Raspberry pi v2, imx219 camera modules, please review the spec to check you’ve enable the camera sensor correctly.

I followed the steps as you suggested. In the first step, I ran the command

DISPLAY=:0.0 nvgstcapture-1.0

. It threw an error and an ‘nvgstcapture-1.0’ window appeared which mirrors the content from my device. I went through the article you provided but didn’t find any relevant information.

Subsequently, I attempted to test the camera with the

gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! 'video/x-raw(memory:NVMM),width=3264, height=2464, framerate=21/1, format=NV12' ! nvvidconv flip-method=0 ! 'video/x-raw, width=816, height=616' ! nvvidconv ! nvegltransform ! nveglglessink -e

command, but the issue persists.

Would you recommend me to reinstall the system? I’m really struggling to find the root cause of this problem.

hello 901026ben,

please check my previous comment #9 for using basic v4l utility to fetch frames.
it’s sensor side issue if that’s still reporting video4linux video0: frame start syncpt timeout!

So you think that is the camera problem?

hello 901026ben,

is it possible to probe the MIPI signaling to ensure there’s data on the CSI channel?

how to probe the MIPI signal to ensure there is data on the CSI channel?

this may need arrange hardware resources, you’ll need an oscilloscope to check the signaling is following the MIPI spec.

I want to bring my device to your service center in Linkou for an inspection. Could you please let me know if this is possible?

hello 901026ben,

had you also consult with sensor vendor to confirm the known good Jetpack release version?

I try to monitor the system status using the sudo jtop command, it reports that it cannot detect JetPack (displays “Jetpack NOT DETECTED”)
but i run dpkg-query --show nvidia-l4t-core command it shows that i have jetpack (version: 32.7.4-20230608212426).
Is that the reason causes the previous problem?

JTop is not maintain by nvidia. anyways, this is a minor issue for Jetpack undetected.

I am an engineer at Trident Pacific Inc. . I would like to bring our Nano to your Linkou center for you to help diagnose the issue.

I’m not sure who you contacted with, also don’t know where it is.
Are you contacting with the vendor?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.