issues with 430.x series + 4k Dell monitor , screen turns off

I am having issues with the latest 430 series drivers. When the driver is loaded my Dell 4k screen (P2715Q) turns off saying it does not receive a signal.
I tried various version of 430, but when I use the NVIDIA .run file to install the screen also turns of after the installer completes.
Debugging this is hard is there is no screen and at bootup ssh is not yet started when the screen turns off.

The older 418.74 driver just works fine, as is the nouveau driver.

Kernel: 5.1.16
OS: Fedora 29 x86_64
Monitor: Dell P2715Q, connected via DP to miniDP
Videocard: GeForce GTX 1070

There are no issues with 430.x when:

  • a connect another monitor (not 4k)
  • a connect both the Dell 4k and another monitor (!)

When only the 4k Dell is connected, the screen turns off.

Any thoughts?

Can you switch to a VT using ctrl+alt+f1 when the screen is off?

No, I cannot. The screen stays off. Even booting to ‘level 3’ does not work as the driver still get loaded and the screen turns off.

Managed to ssh in after the screen turned off. Dmesg reveals:

[  342.657345] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000987d:0:0
[  355.074458] NVRM: GPU at PCI:0000:01:00: GPU-635a32c0-ec87-e4a3-91ed-e0b2347627bd
[  355.074465] NVRM: GPU Board Serial Number: 
[  355.074467] NVRM: Xid (PCI:0000:01:00): 16, Head 00000000 Count 00000005
[  363.266520] NVRM: Xid (PCI:0000:01:00): 16, Head 00000000 Count 00000006
[  371.458592] NVRM: Xid (PCI:0000:01:00): 16, Head 00000000 Count 00000007
[  379.650659] NVRM: Xid (PCI:0000:01:00): 16, Head 00000000 Count 00000008
[  387.842715] NVRM: Xid (PCI:0000:01:00): 16, Head 00000000 Count 00000009
[  396.034774] NVRM: Xid (PCI:0000:01:00): 16, Head 00000000 Count 0000000a
[  404.226846] NVRM: Xid (PCI:0000:01:00): 16, Head 00000000 Count 0000000b
[  412.418903] NVRM: Xid (PCI:0000:01:00): 16, Head 00000000 Count 0000000c

I also tried running nvidia-bug-report.sh from the remote machine but that did not complete. Xorg cpu usage went to 100% on 1 core.

You can run nvidia-bug-report.sh with option --safe-mode to possibly avoid the hang.
What’s the exact brand/model of your gpu?

card is a MSI Gefore GTX 1070 Gaming X 8G

the ‘–safe-mode’ run did complete (I cannot upload the gz file it seems).

One thing to note: after completing the nvidia-bug-report from a remote system and giving a shutdown cmd, the ssh session is terminated but the system never shuts down. Ping keeps working. Hard power off is needed to really turn off the system.
nvidia-bug-report.log.gz (52.2 KB)

Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Got it, thanks. Bug report added.

Since this is obviously a driver regression, maybe also mail it to linux-bugs[at]nvidia.com for additional attention.
Out of curiosity: in previous cases with this error, it was possible to circumvent it by simply enabling CSM in bios. Is this also possible in your case?

I’ve sent a mail to linux-bugs. I am a bit hesitant switching to CSM mode to try out as I have a UEFI only setup.

You misunderstood. It’s not about switching boot method, it’s just about enabling the CSM, not using it or disabling EFI boot.

Right, got it. Check my BIOS, CSM was already on. Disabling it makes it worse. Then even a dual monitor setup does not work. Then both monitors go into power safe.

lol, ok. Is any of this happening on the 418 driver with CSM disabled?

With 418.74 and CSM disabled it works just fine with single screen (4k) and dual screen setup.

I’m facing this issue as well and it’s probably the same as https://devtalk.nvidia.com/default/topic/1052207/linux/nvidia-430-14-monitor-disconnects-when-x-starts/

Also, my setup is the same:

  • Dell P2715Q 4K
  • GeForce GTX 1070

The workaround is not friendly: On boot, If I plug the monitor onto the onboard vga and wait for the initial output, then I can re-plug it onto NVIDIA card and it will work.

@lintweaker, would you check if that works for you as well?

Also, if it helps, there’s a log entry that is present when using 430.xx that is not present on previous versions:

nvidia-modeset: WARNING: GPU:0: Lost display notification (0:0x00000000); continuing.

If anyone is using Arch, I’ve created a PKGBUILD for forcing using 418.74 release: https://github.com/kriansa/PKGBUILDs/tree/master/pkgs/nvidia-418

kriansa, what’s the brand/model of your 1070?

It’s a GigaByte GTX 1070 G1 Gaming

@kriansa, the other issue you referred to indeed seems the same.
Currently I am back on 418.74 as a workaround or I can use my ‘temporary dual screen a boot’ trick. But I think now it is time for Nvidia to step in :-)

I tried on system Precision T7610 which has Genuine Intel® CPU @ 2.30GHz; installed Ubuntu 19.04 with kernel 5.0.0-13-generic; GTX 1070 + Driver 430.34 and used 4K display but not able to repro issue.

Can you please provide xrandr output and confirm if you are using dongle or DP cable to connect display.

amrits, all three reports were about using the Dell P2715Q monitor.