Issues with dlib and face_recognition Jetson Nano Developer Kit

I’m using jetson nano, this one

I followed the steps and installed jetpack 4.6 and tensorflow following steps from the official nvidia site
https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html
I want to run facial_recognition code,
I installed dlib using the
pip3 install dlib
command. Ive tried alternative options of installing dlib. Ive tried this

$ wget https://github.com/davisking/dlib/archive/refs/tags/v19.22.zip
$ unzip v19.22.zip
$ cd dlib-19.22
$ python3 setup.py install --user

Somewhere on a forum someone said that previous version of numpy 1.18.5 or 1.19.4. Tried both but still getting errors.
at running
import dlib
command in terminal i get “illegal instruction (core dumped).” and when i run the python file with the face_recognition code i get “segmentation fault(core dumped).”
The strange thing is I have other codes for mask detection that willl detect persons mask and tested another code that will detect person’s distance. Both codes ran and showed results but only when I run the face_recognition code it shows the segmentation fault core dumped. And when I run the "import dlib " then i get illegal instruction (core dumped)
I am completely new to jetson nano, and where I’m from no one knows much about this either, I’m at a deadend at what to do. I think it is issues with the dlib but I don’t know what to do.

Hi,

Could you try to export the below environment variable first?

$ export OPENBLAS_CORETYPE=ARMV8

Thanks.

1 Like

I finally got it to working, I uninstalled dlib with
pip3 uninstall dlib
and oddly enough when i ran the code it actually worked, I dont know what happened maybe it uninstalled any “extra” dlib i had installed