Issues with permissions in /usr and other jetpack/ubuntu folders

So for some reason, all of the files come with the jetpack, along with the entire computer it seems in a “Other location” under the computer location. I have no permissions in the computer location. In order to even begin running things, I had to move all the folders in the /usr to the directory into the home folder. This allowed me to run all of the samples from the new directory since I can’t touch the /usr files and start working with open-cv (I don’t know if opencv would have worked if I had not done this but). Basically, I can’t do any modding of files, can’t delete anything, can’t install anything into the /usr directory etc. This wasn’t a problem originally but now it is starting to interfere with some of the tutorials that I am following and I feel like something is wrong seeing people talking about /usr directory.

If you use a host which uses a native Linux file system type (e.g., ext4), then that will preserve the reference file system permissions while creating an image. If you have instead unpacked anything to a non-Linux file system, e.g., NTFS or VFAT from a Windows system, then all of the permissions would be incorrect. I don’t know if this is the case for you, but the first question needing to be answered is if any of the software ever ran on a non-native Linux file system type during flash?

The second issue is that there are cases where sudo must be used. JetPack and SDK Manager will ask for your password to run sudo, and so that isn’t usually a problem with that method. However, if you flashed on command line, then the added question is whether you used sudo for the command, the command, and unpacking the sample rootfs.

Can you describe your host PC computer, especially if it is not a regular install of Ubuntu?

Yeah so, I’ll have to get back to you about the flash, I did not flash it(I am on an FRC team so some one else on my team flashed it) but I think it was flashed using windows? I will ask tommorow how it was flashed however it was most likely flashed through windows. I do have an Ubuntu vm if re-flashing work through that? This is the Jetson nano board for clarification.

Flash cannot be done from Windows (the flash binary is a Linux executable). If Windows was used, then it means a VM was used. A VM can work (usually takes some work to get USB to pass through correctly and is not officially supported), but if NTFS was used and not a native ext4 Linux file system, then what got flashed is incorrect and it must be flashed again. The entire file system will be subject to incorrect permissions…thousands of files will slowly show up as wrong over time.

You can test for whether an incorrect file system on the flashing host is the cause of issues. Run the command “sudo ls”. If it allows you to enter your password and see the ls command output, then you are ok. If not, then an incorrect file system type was used on the host PC and this cannot be fixed (well, technically it could be fixed if sudo worked, but sudo won’t in that case).

If it turns out that this is not an issue of the file system type on the host, then we can debug more from there.