Jetbot Collision avoidance example GPU transfer not working

I tried the jetbot collision avoidance example. After the data collection, I followed the steps in the train_model_resnet18 notebook. However, I couldn’t transfer the model for execution in the GPU. After commanding, the cell number was not there

Hi l.hernando.tan,

Thanks for reaching out!

This may mean the Jupyter Notebook kernel has crashed. Do you mind providing the following information

  1. What device are you calling the training script from (On jetbot, or on desktop)?
  2. If on JetBot, did you shut down all other notebooks before running? It’s possible the notebook ran out of memory.

Best,
John

Hi john,

I am calling the training script from my laptop.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Hi l.hernando.tan,

Hmm, have you used PyTorch w. GPU on your laptop before? Do you mind sharing more information about your system setup?

  1. OS
  2. GPU
  3. PyTorch Version

Best,
John

In “https://jetbot.org/master/examples/collision_avoidance.html” it states that the training can be done on the Jetson Nano by "Open and follow the train_model_resnet18.ipynb notebook.
I tried that and got the same issue as l.hernando.tan.
It ran until the cell containing:
device = torch.device(‘cuda’)
model = model.to(device)
Then the kernel may have died and restarted but did not show that the cell was processed.
Trying to run the following cells did not work as previous variables were lost.

@brian34,

Are you running the latest version of the Jetbot software?

Instead of installing Jetpack and then the Jetbot software, there is a complete 20 GB zip image available.

If you are still having trouble running the training, you might want to install the latest Jetbot software.

Regards,
TCIII

where it the link

I faced the same issue. Later I used JetBot image and every thing worked perfect. You can download all the versions of JetBot image in this link Using SD Card Image - JetBot