Jetbot CSI Camera Issues

Can someone help me please? I’ve been working on my Jetbot and have ran into a problem with the CSI camera. On Jupyter Notebook, on the teleoperations notebook, when I go to run the code:


image = widgets.Image(format=‘jpeg’, width=300, height=300)

display(image)

AND

from jetbot import Camera

camera = Camera.instance()

AND

from jetbot import bgr8_to_jpeg

camera_link = traitlets.dlink((camera, ‘value’), (image, ‘value’), transform=bgr8_to_jpeg)


I go to run all of these scripts and it just creates an empty sort of placeholder. There is no feed coming in from the camera displayed in that box area or placeholder.

No errors are being shown, just no live camera footage from the CSI Camera!

Please help me, and thank you.

Do you confirm the system have loaded camera driver correctly?
Maybe confirm by below command.

v4l2-ctl -llist-devices
v4l2-ctl --stream-mmap -c bypass_mode=0

How do I know if the camera has loaded successfully, I just ran those commands?

Im reflashing the jetbot image. I’m using the jetpack 4.5 image for my jetson nano 2gb from Using SD Card Image - JetBot. I am then also installing the latest jetbot 2gb image on top. This time I will not update the system. Last time I did a full update of about 500 packages and dependencies, there were some errors. So this time I will just leave the image how it is.

What’s you camera? What the result by the v4l2-ctl?

The camera I’m using is the imx219-160 model for my jetbot. When I use the command, v4l2-ctl -llist-devices and v4l2-ctl --stream-mmap -c, it just says: command not found. Do I run this in the Jupyter notebook’s terminal or directly in the Jetbot’s Jetson Nano terminal?

Run it jetson terminal.
May need install by below command.

sudo apt-get install v4l-utils

Oh yeah, and this is what I get when I run the code to display the camera feed.

It’s just empty.

I ran v4l2-ctl -llist-devices:

and

v4l2-ctl --stream-mmap -c bypass_mode=0

Looks like your camera have problem to capture frame to Nano.
It could be HW or sensor driver problem. Please consult with sensor vendor to get support.

Thanks

how do i detect to see if my camera is connected to the system. and could this be a software problem with jetpack 4.6.5 and the jetbot image