Jetbot Software Setup Jetpack 4.5.1 Version

In NVIDIA-AI-IOT/Jetbot, What doe this mean, exactly? There is no hot-link to the “oem-config”. ???..+ attention To use a sdcard image that is based on JetPack 4.5, you need to run through the initial (“oem-config”) setup using the original JetPack 4.5 Jetson Nano SD card image (Nano 2GB, Nano (4GB)) first.
This step will configure the bootloader on Jetson Nano hardware as needed for the latest SD card we released for JetBot.

These links are downloads, not procedures. I did the download and booted a 64GB SD, But df -h displays 22GB of 24GB used. & 7 GB additional folders. Where is the remanding space on the 64 GB SD?

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/flashing.html#wwpID0E0EE0HA

Thanks. Is editing the oem-config tool got anything to do with my question about the memory allocations? Can you suggest a specific item to adjust to fully utilize the 64g?

Hi phreddog24,

Regarding 64GB SD card image utilization, do you mind sharing which exact SD card image download you used?

Regarding oem-config, this simply refers to the initial “Ubuntu” setup when you boot with the original JetPack 4.5 SD card image. You’re not alone in your confusion here, you may find this GitHub issue relevant for more information

I’ll work to clarify the wording since it has seemed to raise confusion for others as well.

Please let me know if this helps or you run into any issues.

Best,
John

Hi again and thanks. I use a burn method I have used many times for Nanos and Raspis., namely SD Card Formatter and Balena Etcher. I’ll simply try again later today with another new 64 GB SD Card and report that.

Hello phreddog24,

We found out that the nvresizefs service in the latest jetbot image was not properly configured.
This is designed to auto expand the APP partition to take up the whole remaining space on your SD card on the first (or the next time after configured) boot.

While we work on fixing and remaking the image, will you try triggering the service manually by following the step below?

cd ~/jetcard
git pull
git checkout jetpack_4.5.1
./script/jetson_install_nvresizefs_service.sh
cd
rm -rf jetcard
sudo reboot

Please let us know if you have any questions.

I burned a new SD Card with a Balena Etcher on a new Gigastone 64GB U3 A2 V30 with the same result in my Jetbot. Is there a “log” file I could send you that would assist? Ross
IMG_7481.jpeg

I should have added that I burned another brand, San Disk U3 A2 with the same image as I reported earlier and another Sandisk with jetson-nano-jp451-sd-card-image.xz that expands to sd-blob-b01.img that properly expands to 64GB. Ross

Hi Ross,

You can keep the flashed SD card as it is.
After you boot with it, can you issue the following commands on that system? (with the Internet connection)

cd ~/jetcard
git pull
git checkout jetpack_4.5.1
./script/jetson_install_nvresizefs_service.sh
cd
rm -rf jetcard
sudo reboot

Cyato, jaybdub , thank you for you messages. I can report that this procedure, when applied to a newly configured 64GB SD Card, correctly expanded the Size from 24 G / Used 22 GB on its 1st boot to 59G after running the script and Reboot.

I should mention that I tried to perform this procedure on my original SD Card, at the Git Pull, got error message of insufficient space. So I did a clean new flash to apply the patch.

I appreciate your prompt response and glad I was able to assist in fixing this glitch.i presume a new image will be posted?

jetbot@nano-4gb-jp45:~$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mmcblk0p1 59G 22G 35G 39% /
none 1.8G 0 1.8G 0% /dev
tmpfs 2.0G 4.0K 2.0G 1% /dev/shm
tmpfs 2.0G 19M 2.0G 1% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 2.0G 0 2.0G 0% /sys/fs/cgroup
tmpfs 397M 0 397M 0% /run/user/1000
jetbot@nano-4gb-jp45:~$

Regards
Ross