Unable to flash 63GB JetBot image, how to update nano image to JetBot on SD card?

I got Sandisk 64GB uSD card, but the size is 62.5G after formating.
It is unable to flash JetBot 63GB image, but Nano image only.
How to update nano image to JetBot image on SD card?


Hi brianc5ig7k,

If you are using Windows, it may be seeing the biggest partition/drive of the SD card after being flashed with Nano image once.
In that case, would you use SD Card Formatter to format the entire SD card first and check the size?

Hi, yes I did use SD card formatter with eFAT format in Win10, and tried to flash in win10 or ubuntu 17.10 but it still got 62.5G that Etcher won’t allow to pick 63G image to flash. Is there a way to add-ons JetBot files on top of Nano image?

Yes, you can follow this wiki page to create the SD card from general Jetson Nano image.

Just for our reference, it would be great if you can share with us the result of fdisk -l /dev/*** on your Ubuntu machine.

This is Sandisk Ultra uSD 64GB with nano image as below:
Disk /dev/sdb: 58.3 GiB, 62587404288 bytes, 122241024 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: D048AD43-24FD-4DED-B06E-7BB8ED98158C

Device Start End Sectors Size Type
/dev/sdb1 24576 25165790 25141215 12G Linux filesystem
/dev/sdb2 2048 2303 256 128K Linux filesystem
/dev/sdb3 4096 4991 896 448K Linux filesystem
/dev/sdb4 6144 7295 1152 576K Linux filesystem
/dev/sdb5 8192 8319 128 64K Linux filesystem
/dev/sdb6 10240 10623 384 192K Linux filesystem
/dev/sdb7 12288 13439 1152 576K Linux filesystem
/dev/sdb8 14336 14463 128 64K Linux filesystem
/dev/sdb9 16384 17663 1280 640K Linux filesystem
/dev/sdb10 18432 19327 896 448K Linux filesystem
/dev/sdb11 20480 20735 256 128K Linux filesystem
/dev/sdb12 22528 22687 160 80K Linux filesystem

Why not use 128G SD Card ?

I tried to flash 63GB image into 80GB HDD then found the actually partition is < 58GB.
I will try to clone the 58GB partition back to 64GB uSD card.


You should be able to search for your SD card from Etcher and select it. Unfortunately, it does not seem to pickup larger SD cards. It should run fine once the SD card is selected.

I did this on Ubuntu 16.04 using Etcher and then running gparted and let it fix the unused space on the card. I did format the SD card using ‘mkfs’exfat’ prior to burning the image though. I’m booted on the same 64Gb SD card with this writing.

NOTE: I am using the same 64GB SD card listed in the Bill of Materials.

After being unable to flash the May 2019 jetbot_image_v0p3p1.img on a 64GB SD nor the suggested smaller image, I was successful on a 128 GB SD using Win10 Win32DiskImager (ver 1.0.0). Tried Etcher but appeared to hang. Windows Disk Management reports 59.61 GB, 56.53 GB unallocated. So why wouldn’t a 64 GB work? 128 GB only $5 more cost so probably advisable use anyway. Should NVidia recommend 128 GB SD?

Further to my post, the resulting usable partition is 56 GB on the 128 GB SD with the remainder undefined. Anyway to expand the usage to entire 128 GB as can be done with Raspbian? Boot and Linux Bionic configuration process proceeded per the documentation.

@phreddog24 's right, I just spent an afternoon to realize that it’s Etcher that does not work with a 128GB CardSD. It breaks the partition right from the start and says that it can not flash because it does not detect the SDCARD.

Grrr …

Win32Imager work well!

That’s strange. I’ve used Etcher to flash 256gb cards without a problem. You’re flashing on Windows? I’ve done it from Windows 10 to a Sandisk Ultra 256GB card, though not this particular image.

It is possible you have a fake card with hacked capacity. Etcher does a verification pass. I don’t know if Win32Imager does. The image might flash but not read back correctly, if at all. Can you test the card with F3 for Linux or H2testw for Windows?

Nvidia updated the SD Card Image to “jetbot_image_v0p3p2.img”. Formating the SCD Card with SD Card Formatter by SD-3C and burning with balenaEtcher 1.5.51, can burn about 20 GB usage on a 32 GB SD Card. Appears to expand the image to the entire card. 128 GB card seems unnecessary.