128gb MicroSD card: verification failed after writing Jetson Nano dev kit image

My 128gb microsd card always shows that the verification failed after flashing the jetson nano dev kit (https://developer.nvidia.com/jetson-nano-sd-card-image). I am using balenaetcher 1.5.109 on Windows 10, using Samsung EVO Plus UHS3 128gb.
image

I can successfully flash into my 16gb card using the exact same method.

From this thread, it suggests making the image using the tools in the JetPack:

But, the SDK manager (JetPack SDK | NVIDIA Developer) only runs on linux… Any ready made 128gb image? Any other methods?

You may need to check the card. The error says that the image write and read are not the same.
On the first boot there will be a script to help extend the rest space of the card. So you don’t need to make a 128GB Image expecially.

The card is working fine. I can reformat it, access and store stuff with it. Could you be more specific as to what exactly to check on the card?

I have tried on all my 4 128gb cards, and all of them have the same error. When I turn on the Nano, it only shows the Nvidia logo, and stays there. Definitely not a power issue as I am using a 5V/4A power, and the green light on my nano is a stable solid green.

On another note, the 16gb card I could successfully flash the image to, it also stops at the Nvidia logo.

Could there be something else on my windows laptop that I need to set?

I followed this guide to the dot. It’s precisely because the answer isn’t found in this document, nor in the forum, that’s why I started this new topic…

Getting frustrated…! Help!!

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Pls share the log captured with UART.