I can't flash Jetson Nano 2gb image to 128 GB SD card

I can’t flash the image to a 128 GB SD card. I downloaded the image from https://developer.nvidia.com/jetson-nano-2gb-sd-card-image , actually, I downloaded it 2 times, checked hash and it’s the same for 2 files (to check the file isn’t corrupted). Then I formatted the SD card using SD Memory Card Formatter. After that, I tried to use balenaEtcher - I choose the zip file, choose the SD card, press Flash but I have an error: “Something went wrong. If it is a compressed image, please check that the archive is not corrupted. User did not grant permission”. I also tried to run balenaEtcher as an administrator - it didn’t help. Also, I tried to use Rufus - It also shows an error after approximately 60-70% of progress. Maybe relevant info: Rufus shows the file system is Large FAT32, cluster size = 32 KB - I can’t change these settings. Also, I tried 2 different card readers. The SD card is 128 GB from Samsung and it must be legit.

UPD: Also, I’m trying to do it on Windows 10

Hi @darinhodson

Sdk manager can be another option for you.

I solved the problem. The problem was in Etcher