Flashing NVIDIA Jetson Nano 2GB using SanDisk SD Card (32GB)

Hi all,
I am an engineering student setting up my new Jetson Nano 2gb Developer Kit, but I an unable to flash the OS on my MicroSD card. I have tried flashing it multiple times and on multiple laptops and used the software direct from the ‘getting started’ page of NVIDIA. When the Etcher software is finished flashing, multiple removable drives show up in File Explorer and I am getting 20 pop-up windows from File Explorer saying things like “You need to format the drive” and “The parameter is incorrect”.

Any suggestions on how I can get my Nano working or is there another method to flash the OS onto the SD Card. Also, How do I know if the flash was successful?

Thank you.

PS: MicroSD Card - SanDisk 32gb

Find a x86_64 ubuntu 18.04 host and flash your whole board with sdkmanager.

I mean just forget about the Ethcer.

As I don’t have a Linux system, is there any alternate solution for Windows?

I just got another report from other user regrading the latest nano 2gb sdcard problem.

Maybe there are some issues here. We will investigate it and report to you later.


If you don’t use the latest version, but some older release, will your board work?

Also, please tell us the version of your Balena Etcher.

@Deeksha_Manjunath – that sounds like the SD Card flash actually worked. An SD Card written with JetPack has about 20 partitions, most of which are not recognized by Windows (they are linux or various or other styles of partitions that allow the Nano to boot up).

If Etcher says the flash was successful, you can ignore those Windows popups, and instead it’s worth attempting to put the SD Card into the Nano and power it up. :-)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.