[Solved] Warning Disk Space Remaining using a 64 GB SDcard

Dear all,

After I try to run 3 deepstream-testapp1-3 several times, I got this warning.

Examine

$ df -k

How to solve it? Currently I use a 64 GB SDcard, do I need to use a 128 GB SDCard?

Thank you very much in advance.

Warmest Regards,
Suryadi

Dear all,

I have installed Jetpack 4.2.1 at a 128 GB SDcard.
$ df -k

Why is the size is still same with a 64 GB SDcard (14.384.136)?
Current use is 78%, because I have not installed gparted, canberra-gtk-module, Jupyter Lab, TeamViewer 14 and its dependency, also sudo apt update yet.

$ gparted

How to full utilized a 128 GB SDCard (unallocated 105.08 GB at the end)?

What “-s 16 G” option and why using that size?
I have 105.08 GB unallocated space with a 128 GB SDCard.

Thank you very much in advance.

Warmest Regards,
Suryadi

Today, I try to format a 64 GB SDcard using

$ sudo mkfs.ext4 /dev/sdd
Etcher jetson-nano-sd-r32.2-2019-07-16.zip 
$ gparted

Resize /dev/sdd1 (from 11.9 GB and get unallocated 47.48 GB)

I put a 64 GB SDcard into Jetson Nano and it boot successfully.

$ df -k

Then I use SDK Manager to install tools into Jetson Nano without flashing Jetson Nano OS.

Thank you.

Hi suryadi,

Good to know you can flash success now :)

For below command is example, you can change the size with “-s” option.
$ sudo ./create-jetson-nano-sd-card-image.sh -o sd-blob.img -s 16G -r 100

My goal was to build the Jetpack4.2.2 on a 64 GB SD Card for the Nano Development System.

I used the SDK Manager to install Jetpack4.2.2 on a 64 GB SD Card.

The result was an APP partition of 14 GB as the first partition.
The remaining partitions were installed following the APP partition and before the un-allocated space or approximately 45 GB at the end of the sd card space.

The Nano Development Board booted up but quickly ran out of SD Card storage.
Because the APP was first and the other small partitions immediately followed, no partition tool I
tried could resize APP to more then 14 GB.

I started from scratch and created the SD card system manually, not using the SDK Manager.
The partition order was all small partitions came first, with APP being last with un-allocated space adjacent to APP. gparted resized the APP partition to approximately 63 GB.

Everything worked great.

My request is to free up development from requiring an SD Card based Boot and Storage media.

Instead, enable the SDK Manager to format USB attached NVME SSD storage like the Intel 660p, etc.The Intel 660p I used is contained in a Pluggable NVME SSD case that attaches to USB3 or USBC, etc. It works fine with the Nano Development system USB3 ports.

Anybody have any ideas?

Thank you in advance.