Jetpack 3.2.1 hangs after flashing the OS

Jetpack flashes successfully but during the ssh installation it hangs and doesn’t continue to install the packages like cuda etc. I tried to do it manually using Jetpack by selected package installation, in the GUI mode it request the username and password, later in the shell window password prompts 3 times and just the cuda package is copied to jetson tx2 and not installed, also shell freezes after copying.

Thanks in advance.

If you are using a VM failures like this are common. In the case of ssh failing it might be the keys are not set up correctly. You should see if “ssh nvidia@” (pass “nvidia” unless you changed it) works from command line.

Hi, am not using VM. Os is ubuntu 16.04.

How did the ssh test go listed from #2?

Since it was stuck after copying cuda packages, I exited from the installation and tried to manually ssh to the target. Ssh works fine, but I cant setup for a passwordless login by copying the keys to board.

I assume you are talking about “ssh-copy-id”. If possible, please post the command used and the output of the copy-id failure.

FYI, on the Jetson you could delete the “~nvidia/.ssh/authorized_keys” to remove current key knowledge and start over on keys. You could delete the “~nvidia/.ssh/known_hosts” to further remove knowledge of previous ssh allows.

You may want to further test with scp since this is how copies are done. Example from host (replace “x2” with the IP address of your TX2):

echo "testing" > deleteme.txt
scp deleteme.txt nvidia@x2:/home/nvidia/Downloads
rm deleteme.txt
scp nvidia@x2:/home/nvidia/Downloads/deleteme.txt .
cat deleteme.txt
rm deleteme.txt

I don’t know for certain, but perhaps root on your host is at times doing the scp. So try the above with “sudo” as well. You can run “sudo -s” to drop into an sudo shell and stay root, do all of the above testing again, and then type “exit” to leave the sudo shell. For root directories would be “/root/.ssh/” instead of “/home/nvidia/.ssh/”.

Hi, ssh is working as normal, copied the key to the target and changed to authorized_key but still I cant get the passwordless ssh login. Also the super user privileged is not available. Once I type sudo apt-get update " /usr/bin/sudo must be owned by uid 0 and have the setuid bit set". I couldn’t complete the flashing of the packages and it might be because of unsuccessfully flashing.

Aha! are saying “sudo” fails! This would be a failure to preserve permissions during the flash. An example is if running the host flash from a non-native Linux file system type, e.g., NTFS or a Live DVD since a DVD uses an overlay filesystem type not supporting full permissions. Is there anything unusual about the host PC’s file system where JetPack was run? Try to cd to the JetPack directory and run:

df -H -T .

(the " ." is important, it implies the current directory)

See if it is something other than ext4.

Exactly!, its not ext4. Due to lack of space in the partition I will try reinstalling the OS and do a fresh installation of Jetpack. Can I try with UBuntu 16.04.4LTS

Hi, I formatted a new partition with ext4 and tried reinstalling the Jetpack and its done successfully. Os was Ubuntu 16.04.3LTS and everything works fine even the ssh. Now I gained the root privilege too. Thank you linuxdev for troubleshooting the issue. Jetson tx2 is up and working.

Thanks a lot.