JetPack 3.3 failed to install CUDA on TX2

JetPack 3.3 failed to install CUDA on TX2 as we selected the second network layout (via host machine through setting a new DHCP server configuration on host). Even we manually installed CUDA from JP33 after OS was installed.
The error message is as attached.

Due to the environment limitation, we only can use host with wifi connection and selected the second network layout to install Jetpack to Tx2.

Thank you for any advice.

Added more information

Host: Ubuntu 16.04.5


Could you try to apply these commands to see if helps?

1. apt-get purge cuda-license-<version>
2. apt-get purge cuda-repo-*
3. dpkg --remove-architecture arm64
4. apt-get update
5. apt-get install g++-aarch64-linux-gnu
6. Reinstall CUDA with JetPack

If not, could you share the log in <JetPack_Dir>/_installer/logs with us?


Hi AastaLLL,

Thank you for your prompt support.

I’m afraid the command does not work.
After we applied the commands and Jetpack 3.3 hanged after finish flashing OS. (over 10 minutes)

The message is as the following (see attached)
“ Finished Flashig OS
Determining the IP address of target”

Even running Jetpack3.3 secondly, still failed.

The message is as the following (see attached)
"Error: Cannot connect to device with given information. "

Plus, when we used Ubuntu 14.04 as the host to install Jetpack 3.3 with the second network layout, it worked.
However after successfully installed, the host could not connect WIFI either.

Due to the environment limitation, we only can use Ubuntu 16.04 to be the host.
We still expect to get the solution of using Ubuntu 16.04 as the host.

Thank you,

FYI, you can uncheck flash. You don’t need to flash each time you run JetPack…package installs are a separate step. Flash is over USB, packages are over wired ethernet. You can even leave USB disconnected for safety. Any time you don’t flash just boot the Jetson normally without recovery mode.

You will then probably have to enter the IP address manually (watch the console, and on the Jetson check address via “ifconfig”…should be eth0).

Thank you for your information.
We did tested flash the OS and the other AP separately.
Our test environment is as the following:
Host : Ubuntu 16.04
Jetpack: 3.3
newwork layout: the second layout

Attached our test results.

JP_newtwork.xlsx (11.3 KB)

In the case where it fails, does “ifconfig” on the Jetson show a valid address? I assume wired ethernet since WiFi after initial boot isn’t supported for JetPack (the PC can use WiFi to internet, but not WiFi from the Jetson). From the host, can you succeed at:

ssh nvidia@<that IP address>

If you can do that, then run JetPack without rebooting anything. If this fails only under JetPack, then it can be debugged further (include the logs in JetPack if you can for that case).

I have the same error with JetPack 3.3. I have wired ethernet connection between PC and TX2. Jetson TX2 does not get assigned valid IP address. It appears DHCP configuration file dhcpd.conf is not correctly setup during JetPack installation (which is right before Post Installation step). As a result Jetson TX2 does not get IP assigned by the PC and loading CUDA, etc fails.
Can you please share example of a correct dhcpd.conf file for such configuration.

Below is the configuration in /etc/dhcp/dhcpd.conf file which appears to be added by JetPack and does not appear to be working. There is another thread “DHCP not working and on internet connection from TX2 after installing” which mentions the issue. Please provide expected dhcpd.conf file which is known to work.

allow bootp;
subnet netmask {
option routers;
option domain-name-servers Usage:, nmcli, device, {, COMMAND, |, help, }

COMMAND, :=, {, status, |, show, |, connect, |, reapply, |, disconnect, |, delete, |, monitor, |, wifi, |, lldp, }

, , status

, , show, []

, , set, [ifname], , [autoconnect, yes|no], [managed, yes|no]

, , connect,

, , reapply,

, , disconnect, , …

, , delete, , …

, , monitor, , …

, , wifi, [list, [ifname, ], [bssid, ]]

, , wifi, connect, <(B)SSID>, [password, ], [wep-key-type, key|phrase], [ifname, ]
, , , , , , , , , , , , , , , , , , , , , , , , , [bssid, ], [name, ], [private, yes|no], [hidden, yes|no]

, , wifi, hotspot, [ifname, ], [con-name, ], [ssid, ], [band, a|bg], [channel, ], [password, ]

, , wifi, rescan, [ifname, ], [[ssid, <SSID, to, scan>], …]

, , lldp, [list, [ifname, ]]

Error:, ‘dev’, command, ‘list’, is, not, valid. ;
default-lease-time 345600;
max-lease-time 31557600;

In the case of DHCP failing it may be related to the DHCP server. Is the host acting as server, or is there a router appliance? If host, is this a VM?

The host is acting as DHCP server. There is no router. Host is Intel NUC7i7BNH running Ubuntu 16.04 LTS without VM.

In this case I suspect that logs will show the moment a DHCP request goes to it…but the Ubuntu PC might have firewall enabled such that it never sees this. I use Fedora, so I don’t know what log file would have DHCP logs on Ubuntu. However, if you run this on all of these files prior to starting the TX2 (or look for whatever seems obvious, e.g., maybe there is something with dhcp in its name), then most likely you’ll see something:

dmesg --follow
sudo tail -f /var/log/messages
# NOTE: "secure" might say something about access denied.
sudo tail -f /var/log/secure
sudo tail -f /var/log/kern.log

Btw, it is ok for the host to access internet over WiFi. The only issue is that the Jetson itself needs wired. It sounds like you have basics set up correctly and only a configuration problem exists.

So far as dhcpd.conf goes, I thought JetPack would set this up. However, if this is a problem, then I’m thinking maybe if you temporarily disable the existing dhcpd.conf file (e.g., “sudo gzip /etc/dhcp/dhcpd.conf” would be temporary until gunzip), then run JetPack again. See if it regenerates the conf file when telling JetPack to use the host as router.

Thanks. JetPack sets up dhcpd.conf file but likely sets it up incorrectly. I ran JetPack at least 4 times. Every time it generates dhcpd.conf file. I need somebody to post known good dhcpd.conf file for Ubuntu 16.04 for host as a router configuration.

I got a router to try that configuration. I had to reinstall Ubuntu on Intel NUC because network configuration was corrupted by previous JetPack install with PC as router option.
With the separate router configuration complete JetPack installed succussfully in Intel NUC and on Jetson TX2.

JetPack has a defect in setting dhcpd.conf configuration file for the PC as a router configuration option.