JetPack 4.4 Developer Preview - L4T R32.4.2 released

Hi Alexander_1 !,

You have reason, I unpacked the image “nv-jetson-nano-sd-card-image-r32.4.2” and burn the file sd-blob-b01.img, it work finally without any problem.
Thanks for your info!

1 Like

Hi meerbartj,

Finally I can burn the image “nv-jetson-nano-sd-card-image-r32.4.2”, @Alexander_1, suggest unpack the archive and burn the file “sd-blob-b01.img” and it work without any problem, the graphical interface never crash, I burn en three diferent SD Card and no problem.

Thanks for your info.

BR!

1 Like

For the gpu issue that causes the system slow, you could apply this patch to the kernel.

Does anyone have a very lean kernel config? I want all of the unused drivers and bloat disabled.

I tried to burn the unzipped “nv-jetson-nano-sd-card-image-r32.4.2” image, i.e. sd-blob-b01.img, but experienced the same symptoms: graphics freezing already during the installation steps.

I downloaded the nano image fresh (2020-05-11); with this binary the problem seems gone.

Still the same old linux kernel 4.9?
Lol, I lost hope in this company.
Waited almost one year, no changes here.
Can’t even install AX card drivers properly.

I’d like to report an issue about JetPack-4.4 DP here. A more detailed description could be found on GitHub: https://github.com/NVIDIA/TensorRT/issues/562

Basically, I was able to use “trtexec” to build the TensorRT engine from the Caffe SSD_300x300 model and run inferencing with it. However, “trtexec” would seg-fault when deserializing the engine file. More specifically, the seg-fault happened during deserialization of the “PriorBox” plugin.

The above worked in TensorRT 6 (JetPack-4.3) previously. So it does seem a bug introduced in current TensorRT 7.1.0 DP.

Our company does use this feature in the products. We hope this issue would be fixed in the GA release.

Hi @jkjung13, please post this issue as a new topic, so we can be sure to look into it promptly. Thanks.

@dusty_nv, sure. I’ver created a new issue here: TensorRT 7.1.0 DP segfault when deserailizing the "PriorBox" plugin. Thanks.

Any chance you could issue a version of SDKmanager for Linux x64 architecture that can actually talk to a Jetson Nano or NX? Very hard to develop when you point to broken tools.

You don’t have to use SDK manager anymore for anything @Whichway . Tegra devices is now feature apt based OTA updates, and the rest of the files SDKM provides can be obtained independently and are largely architecture independent.

I don’t suppose anyone could update the online documentation to say that. I spend day after day going round and round the site trying to find things that might actually work or at least relevant. How did you find out that SDKManager was no longer useful? Sounds like I should be following that. Thanks.

It used to be necesssary, and I wasn’t much of a fan for a bunch of reasons. With JetPack 4.3, Nvidia remedied that and made me very happy by adding OTA updates so now various Nvidia optional packages can be installed via apt.

Much of the documentation still lists the SDK Manager way of doing things, and it is still necessary if your devices aren’t connected to the internet, or for the inital flash of devices without an SD card reader, but otherwise you can apt-get install almost anything.

Likewise if you’re interested in customizing the OS itself, you can download the various files from tarball. The “BSP” tarball contains the Linux_for_Tegra folder refrenced in some of the documentation if you’re hunting for it.

Hi,

Is there a release date for the final jetpack 4.4 release?

Hi @tvai, the release is in the final preparations to be posted, it should be online in the coming days - stayed tuned.

1 Like

Looks like the full JetPack4.4 came out today and now supercedes the JetPack4.4 developer preview.

great news! is there a full changelog somewhere? more than the official one about cuda 10.2, cudnn 8, etc

Another question, what is the revision name in this case, is it the same as the DP: r32.4.2?

See the announcement thread:
https://forums.developer.nvidia.com/t/jetpack-4-4-l4t-r32-4-3-production-release/140866

You might need to log in to get to this, not sure, but change log:
R32.4.3 Release Notes

A “DP” is a developer preview, and not a full release. The actual R32.4.3 is a full release.