Jetpack 5.0, pytorch container, container toolkit not found

I am running jetpack 5.0 on an Xavier AGX, and pulled the latest pytorch container which runs on jetpack 5.0. However, when I launched the container, it warned me that the nvidia driver was not detected, and that I should use the nvidia container toolkit to start the container. I followed instructions to install the toolkit but it seems as if I already have the latest toolkit: nvidia-docker2 is already the newest version (2.10.0-1). My daemon.json in /etc/docker is:
more daemon.json
“runtimes”: {
“nvidia”: {
“path”: “nvidia-container-runtime”,
“data-root”: “/media/bruce/lab/docker”

Any insight on how to fix this (or that this is a known bug) would be greatly appreciated. Thanks, and thanks for getting Jetpack 5.0 out. When it is all working it is going to be so great to leave 18.04 in our rear view mirror.

Did you install nvidia-jetpack? sudo apt install nvidia-jetpack, I think it has docker-nvidia.

Thanks for the reply. I did the install as you suggested, and rebooted, but same error.



Which container do you use?
For JetPack 5.0 DP, please try


Thanks so much, that worked like a charm. For what it is worth, I think I had used 22.03-py3.

Can I just say how nice it was to then install ros2 rolling without compiling from source :-) , and to have python3.8 etc. !

Thanks again,


Good to know it works.

For JetPack 5.0, the OS version is r34.1.
That’s why you need a container that has an r34.1 tag.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.