Jetson A203 v2 wifi issue

Hi all,
i wondering if any one has used the A203-V2 carrier board as im having a bit of a problem.
i bought this from and it works well but there is no wifi at all? i installed correctly a intel AC8265 module and for some strange reason it dosent show up in network setting at all. so i thougth mabye i got a broken wifi module and tested it out on the defult B01 carrier board, and it work find right out of the box as i expected, so then that leaves me with two options, either my A203-v2 board has a broken wifi conector i cant see or there are extra steps i have to do like with enabling the fan? i have not attached a ssd to it when i was testeing as i know that they dont work together.

so has anyone esle come across this? im fairly new to the jetson nano but i got the A203-v2 cause i thougth it would be perfect for a Drone project. help would be appreciated.

Jetson nano module has only one set of PCIe interfaces. In the hardware design of A203, this interface is used for SSD (M 2. Key m) interface, so WiFi interface is not supported on nano. If you want to support WiFi on A203, you need to use Jetson NX module.

1 Like

Thanks for Ning’s explanation, when using Nano, only M.2 M key works. When using Xavier NX, the AC8265 wifi module could work.
For further information, you could ask for our customer service (Discord).
Meanwhile, if you have to use Nano, try USB wifi.

1 Like

thanks for telling me, only question i have is that the same for A203 version 2 ?

cool i will use a wifi dongle then, is there a reason why the M.2 E-key dosent work? i find it strange seeing that it works fine off of the defult carrier B01, that being the M.2 E-key.

I think I could answer the two questions together.

  1. A203v2 is an updated version of A203, adding more I/Os and some other small changes, on our bazaar, there is a clear comparison chat between A203 and its V2.
  2. For the Nano’s carrier, it supports one M. 2 M key or one M.2 E key only and therefore, it depends on how the carrier board designed. Thus, you will find default carrier B01 has one E key only and A203 series support M key for Nano only. But powerful Xavier NX could support them both:P.
1 Like

thanks george_gao i think you have solved my problem then

you are welcome!

@George_GAO @ningxuemao2005 I should be able to use the m.2 e key for a network adapter if I’m not using the m.2 e slot for ssd on the A203v2 with the jetson nano production module is that correct? If not are there any m.2 m key network adapters you could recommend? I purchased 12 a203v2 units for the nano production module at the time the unit description stated wifi and ssd m.2 slots not compatible together and because our OS runs on flash memory we thought we’d be ok. Is this possible or will we need to try a converter or usb?

The nano module is used on A203, and the WiFi data line on the interface hardware of M2 key E is not connected. In addition, I didn’t find the WiFi module with M2 key M interface, so the WiFi function should be used for nano module on A203. The best choice is the WiFi module with USB interface.

1 Like

I totally agree with ning’s explanation :P)

i managed to get the wifi working on the M.2 M-key in a weird way, so after my original post i bought a wifi dongle

i intalled the dirver and it worked well, but i wanted to still try the intel AC8265 module on the A203v2, so i thought about buying a NVME to M.2 converter and guess what, it worked and worked well, only one problem it sticks out like a sore thumb lol.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.