Jetson AGX Orin Dev Kit PCIe (Orin RP to Orin EP) Shared RAM Memory Not Working

I have followed the “PCIe Endpoint Mode” instructions from r35.3.1 Developer Guide. I have rebuilt the kernel to disable CONFIG_STRICT_DEVMEM. I can enable to EP Orin and rd/wr to the BAR0 RAM phys.

Although when I run “# setpci -s 0005:01:00.0 COMMAND=0x02” on RP Orin, I get the following message:
"setpci: Warning: No devices selected for “COMMAND=0x02” .

Furthermore, when I run “# lspci -v” it only shows 0001:00:00.0 PCI bridge: NVIDIA Corporation Device 229e (rev a1) (prog-if 00 [Normal decode]) and does not show any mention of “RAM memory: NVIDIA Corporation Device 0001”

Can this test be done using an x4 PCIe cable in the x16 slot?

Please advise!

How did you connect the EP orin to your RP orin?

We had a hardware document for the PCIe EP design. Have you read this ?

I was attempting to use a PCIe Male-to-Male x4 Cable. So it appears I need a PCIe Male-to-Male x8 Cable to run this Nvidia provided Orin RP-Orin EP example.

How do I configure the Orin RP to run in x4 mode?

Can we us the “Endpoint design guide of AGX Xavier” for connecting two AGX Orin SOM.

Please compare your design to the Figure 7-5. PCIe Jetson AGX Orin RP to Jetson AGX Orin EP connection
Example in Orin Design Guide doc.

Where can I purchase an NVIDIA E3317 RX/TX Swap Board?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.