Jetson AGX Orin Gstreamer transcoded and found FPS score lower from Jetpack v5.0.2 GA vs Jetpack v5.0.1 DP

I’m working to generate Nvidia codec engine performance, but found the performance degraded when I got the score from Jetpack v5.0.1 DP higher than jetpack v5.0.2 GA, I’m tun gstreamer transcode pipeline as below:

command line: sudo gst-launch-1.0 filesrc location=~/bbb_sunflower_2160p_60fps_normal.mp4 num-buffers=3000 ! qtdemux ! queue ! h264parse ! queue ! nvv4l2decoder ! queue ! nvv4l2h264enc profile=4 bitrate=8000 ! perf ! fakesink -e

the Video Clip I got from here: curl -k http: //ftp .vim.org /ftp/ftp/pub/graphics/blender/demo/movies/BBB/bbb_sunflower_2160p_60fps_normal .mp4 -o ~ /bbb_sunflower_2160p_60fps_normal .mp4

The score got is here:
|Jetpack|SUT|Transcoded|
|—|—|—|—|
|5.0.2|Nvidia-Jetson-AGX-Orin_Concord_12C12T-2189@WMaxN@Nvidia-Ampere-930-64|95.108|
|5.0.1|Nvidia-Jetson-AGX-Orin_Concord_12C12T-2189@WMaxN@Nvidia-Ampere-930-64|98.341|

Everyone have face this issues? Do you mind to share how to get better performance on Jetpack v5.0.2 GA than 5.0.1 DP?

Hi,
Please enable maximum performance to nvv4l2decoder and nvv4l2h264enc, and check if you still observe the issue.

Hi DaneLLL,
Above score is ran with jetson_clocks enabled. Do I know is there diff configuration to enable MAX performance for nvv4l2decoder & nvv4l2h264enc gstreamer element? please advise and thank you.

Hi,
Please enable the property:
[nvv4l2h264enc]

  maxperf-enable      : Enable or Disable Max Performance mode
                        flags: readable, writable, changeable only in NULL or READY state
                        Boolean. Default: false

[nvv4l2decoder]

  enable-max-performance: Set to enable max performance
                        flags: readable, writable
                        Boolean. Default: false

Hi DaneLLL,
Let me check it and thanks you advise.