Jetson AGX Orin reflash not working

I have a Jetson AGX Orin that boots with warning “Test key is used.” Someone was working and may have made some undesirable changes.

  1. I’ve attempted to use the sdkmanager to flash. The SDKmanager returns a message that the Jetson is “in a bad state” (image attached). I try to put it in recovery mode and reflash and get the same error.

  2. I’ve also followed the instructions from To Flash the Jetson Developer Kit Operating Software. I confirmed that the Jetson is in recovery mode. I match to #7023 for Jetson AGX Orin (P3701-0000 with 32GB). I get error ‘failed flashing t186ref.’ Log for this is attached flashing_like_a_rockstar.txt (362 Bytes)

Is there anything more I can do to try and get this device working?

I am working in WSL. I do not have access to a Linux-only machine. I have confirmed that the USB port is accessible in WSL. I could really use some help to get me over the finishline.


(Quick Start — Jetson Linux Developer Guide documentation)

I don’t see any log from your attachment. Just the steps for what you did.

This does not share any info…

ugh sorry. I’ve rerun the last bit command
screen.log (56.2 KB)
and exported to the attached log.

Hi,

It looks like you are actually using a Orin 64GB module but not 32GB as what you said.

Are you sure your module is 32GB but not 64?

Sorry it is 64. I didn’t realize that 7023 covered both the 32 and 64GB units.

I guess the issue here comes from WSL. Better trying a native ubuntu host.

I’m sorry, are you saying you know what the error is? Because it doesn’t look like an error with my host machine. I’ve gotten the Orin running and it’s “in a bad state.” What would you have me do with a Linux host if I got the exact same error?

Hi,

The 'bad state" has nothing to do here. It is just a common strings that could be from anything else.

It is just like “flash has error but we cannot tell which one has error”.

The flash process is a two side process. One side is your host, and the other side is the jetson.
It could be your host not able to communicate with Jetson during flash process and lead to failure.

Your “screen.log” has more info than that but it is also just host side log.

[ 4.9281 ] Copying signatures^M
[ 4.9307 ] tegrahost_v2 --chip 0x23 0 --partitionlayout flash.xml.bin --updatesig images_list_signed.xml^M
[ 4.9841 ] mb1_t234_prod_aligned_sigheader.bin.encrypt filename is from images_list^M
[ 4.9848 ] psc_bl1_t234_prod_aligned_sigheader.bin.encrypt filename is from images_list^M
[ 4.9848 ] Boot Rom communication^M
[ 4.9877 ] tegrarcm_v2 --new_session --chip 0x23 0 --uid --download bct_br br_bct_BR.bct --download mb1 mb1_t234_prod_aligned_sigheader.bin.encrypt --download psc_bl1 psc_bl1_t234_prod_aligned_sigheader.bin.encrypt --download bct_mb1 mb1_bct_MB1_sigheader.bct.encrypt^M
Error: Return value 8^M

If you want to check more, enable serial console log and dump it during flash failure. That will dump the device side log.

Did you configure USB connection in WSL2 correctly?

There’s a tool by Microsoft for that purpose.

In short, Jetson devices will be connected and disconnected multiple times during flash, and for flashing with WSL2 to work, USB devices have to be transferred from Windows to Linux upon connection, so a tool that can automatically handle this task is required.

1 Like

Yes. I did. I confirmed.

Try more times or use native Ubuntu host PC instead.
USB connection in WSL2 is still not as stable as that is on a real PC.
We don’t really suggest using it even though it’s documented.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.