Jetson agx orin torch 1.11.0 install

I’m using Jetpack 5.1.1(L4T 35.3.1) on the JETSON AGX ORIN device.
I’m trying to run a monai label server on Jetson, and it seems that both CUDA and distributed features of torch need to be available.
The torch 2.0.0 I was originally using only had CUDA available, and the result of distributed.is_available() was false, so I found this post ‘Torch.distributed is not available on Jetson PyTorch’.
In the post, I saw that the last version with distributed availability was 1.11.0, so I installed version 1.11.0 using wget and pip.
But now when I run import torch, an error occurs: ‘OSError: cannot open shared object file: No such file or directory’.
Did I do something wrong or miss something?


Please install the package with the instructions in the below document:

The latest version should be 2.0.

@AastaLLL Can you also mention the steps to install libtorch for c++ purpose

Is there no way to use a version of torch that supports distributed on Jetpack 5.1.1?

1 Like

Hi @yys9905a, when you tried torch-1.11.0-cp38-cp38-linux_aarch64.whl, did you install libopenmpi-dev from apt? Can you find the /usr/lib/aarch64-linux-gnu/ library installed?

You can also build PyTorch from source, like in the PyTorch for Jetson thread or like in this torch-builder dockerfile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.