Jetson AGX Orin / Yolov4-deepsort

I want to track object with YOLOv4-DeepSort.
I am using this documentation. GitHub - theAIGuysCode/yolov4-deepsort: Object tracking implemented with YOLOv4, DeepSort, and TensorFlow.

my pip list:

Package Version


absl-py 1.0.0
easydict 1.9
lxml 4.9.0
matplotlib 3.1.2
numpy 1.22.4
Pillow 7.0.0
pip 22.1.2
tensorflow 2.8.0+nv22.5
tqdm 4.64.0
opencv-python 4.6.0.66

To implement the object tracking using YOLOv4, first we convert the .weights into the corresponding TensorFlow model which will be saved to a checkpoints folder. Then all we need to do is run the object_tracker.py script to run our object tracker with YOLOv4, DeepSort and TensorFlow.

save yolov4-tiny model

python3 save_model.py --weights ./data/yolov4-tiny.weights --output ./checkpoints/yolov4-tiny-416 --model yolov4 --tiny
DONE.

Run yolov4-tiny object tracker

python3 object_tracker.py --weights ./checkpoints/yolov4-tiny-416 --model yolov4 --video ./data/video/test.mp4 --output ./outputs/tiny.avi --tiny

ERROR:
importerror: /lib/aarch64-linux-gnu/libgldispatch.so.0: cannot allocate memory in static tls block
SOLUTION:
export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/libgomp.so.1

RUN AGAIN:

RESULT:
Frame #: 1
FPS: 0.30
Frame #: 2
FPS: 21.05
Frame #: 3
FPS: 58.99
Frame #: 4
FPS: 57.18
Frame #: 5
FPS: 50.28
Frame #: 6
FPS: 45.43
Frame #: 7
FPS: 39.53
Frame #: 8
FPS: 27.85
Frame #: 9
FPS: 32.69
Frame #: 10
FPS: 55.51
Frame #: 11
FPS: 39.98
Frame #: 12
FPS: 44.26
Frame #: 13
FPS: 59.22
Frame #: 14
FPS: 61.25

BUT, does not detecting objects and not drawing boxes

ALSO, when I try it on my computer (ubuntu 20.04) it works fine, just low fps.

what is the problem? why object tracking doesn’t work?

I fixed it.

Solution: Fix the tensorflow prediction (using models.load instead serving) by dacnguyen95 · Pull Request #77 · theAIGuysCode/yolov4-deepsort · GitHub

Hi,

Thanks for the feedback.
Good to know it works now.

Thanks.