Jetson AGX Xavier "Quick Start Guide" not so "quick"

This is mostly a commentary/request regarding documentation.

Commentary
Quick-start guide doesn’t mention any host-pc OS requirements. Being a Windows user, I understand I now need a different OS on my PC to install the SDKManger, just so I can install Jetpack. That’s kind of annoying (especially compared to flashing a microSD card for Jetson Nano/etc, which I can do on pretty much any OS), but ok.

  1. Download/install Ubuntu on a PC
  2. Download/install SDKManager
  3. Install Jetpack via PC to Jetson.

The current Ubuntu version is 20.04. Only on step 2 do I get a cryptic message about not being able to install the SDKManager .deb package.

After some searching, I find the system specs are listed here: https://docs.nvidia.com/sdk-manager/system-requirements/index.html

Ah, I see SDKManager requires an older Ubuntu version 18.04.

For a “quick-start” guide, this is a pretty awkward process full of wasted time/effort/documentation hunting.

I have previously played with the Jetson Nano, and getting that up and running was much easier. I wasn’t expecting such a headache for the somewhat “flagship” Jetson variant.

Request:
It would be kind of handy if there was a simple one-liner above/below the SDKManager download link that simply stated the OS requirements “Ubuntu 18.04”, or linked to the system requirements doc.

UPDATE
Even downloading 18.04LTS, and booting from USB, still ran into error installing SDKManager.

SOLUTION:

I was able to install sdkmanager on an ubuntu 18.04 in the “Try without installing”. I had to open up the “Software & Updates” settings and enable all of the package sources (and disabled cdrom for good measure). After that it worked correctly installing sdkmanager with the gui “Software Install”

Solution was found here: Error with installing NVIDIA SDK Manager ...you have held broken packages

Hi,
Thanks for the suggestion. We may not put System Requirements page in a more obvious place. And we have verified host PC with Ubutnu 16.04 and 18.04. Probably certain packages are installed and may trigger different cases.

The 18.04 I had issues with was a first boot Ubuntu ISO image. Not sure what “certain packages” would be installed in those conditions.

As noted in the solution quoted above, I had to enable alternative package sources.
I ran into another issue though, in that the SDK Manager required more local storage than I had on my USB stick which I flashed with 18.04. I guess at this point I should toss any USB drive 16GB and less in the garbage by now. haha

After all of this, I found that the Jetson AGX came pre-loaded with Jetpack, so all of these steps were completely unnecessary. If I hadn’t even looked at the quick-start guide, I would have been up and running with the Jetson within minutes instead.