Jetson-inference examples do not run with USB-cameras

I connected a few cameras with an HDMI-USB adapter to the nano. Using Chesse I get an image, however the inference examples do not work, see pictures.
I started the examples for instance with: Camera-viewer –-camera=1 and tried different options too. The programs terminate always with segmentation fault, see pictures. The SD is 64 GByte.

One picture shows Cheese (USB camera) and the Camera-Viewer (CSI Camera) running simultaneously on /dev/video1 and /dev/video0.

The other picture shows the crash of the Camera-Viewer at USB3. Afterwards I started Cheese to show, that the USB-camera basically works.
Finally I got an Ubuntu error report. The internet was not connected. Therefore I did not send it.

What may be the reason that the examples terminate?

(Background info: in the future I would like install two cameras onboard of a multicopter, a Sony and a thermal camera, both with HDMI-USB3 adapter connected to the nano.


I am using the same USB adapter used from the author in the video. I think, an inference example is shown.)
Best regards,
Wilhelm



Hi WiSi-testpilot, to use a V4L2 camera (like /dev/video0, dev/video1, ect) with jetson-inference, you need to specify the full path to the /dev/video* device to the --camera parameter. So to use /dev/video0, you would launch the segnet-camera program with --camera=/dev/video0 and for /dev/video1, you would launch it with --camera=/dev/video1

$ ./segnet-camera --camera=/dev/video0

Note that if you just specify a number to the camera parameter (like --camera=1), that means to use MIPI CSI camera, which is a different interface. For more info, please see the documentation of the camera program here (or by running segnet-camera --help):

https://github.com/dusty-nv/jetson-inference/blob/master/docs/segnet-camera-2.md

By default it will try to set your camera to 1280x720 resolution. If this format isn’t supported by your camera, you will need to use the --width=X and --height=Y arguments to segnet-camera, where X and Y are a supported resolution listed by ‘v4l2-ctl --device=/dev/video0 --list-formats-ext’

Dustin, thank you very much for your help.
It works now with the command line from your post.
The --camera=/dev/video0 was the reason, I tried --camera=n.
All example work very nice, see screenshots.
Now I will order a second adapter…
Best regards,
Wilhelm