Problem with jetson-inference project with jetson nano.

Hi,
I have few querries regarding Jetson-interface project with jetson nano.
I am using the jetpack4.2 SD card image with Ubuntu18.04.
I built the project and got the executables in build/bin/aarch64/bin folder. But only “imagenet-console” is runnig good not all.

1)When i run gst-camera i get segmentation fault error.
2) When i run “detectnet-camera”, then it gets heated and gets shutdown after 5 mins.
3) When i run “v4l2-display /dev/video0”, then it says “video device ‘/dev/video0’ has been un-initialized”.
I am using USB camera and can validate the workng of camera with cheese software, it is running.

Any suggestion?
Thanks.
v4l2-display.log (1.59 KB)

Hi,

Could you check if your camera is mounted at ‘/dev/video0’ first?
(You can check it by unplugging)

By the way, which power supply do you use?
For TensorRT app, a high GPU load usecase, it’s recommended to have a stronger power supply.
https://devtalk.nvidia.com/default/topic/1048640/jetson-nano/power-supply-considerations-for-jetson-nano-developer-kit/

Thanks.

Hi,
Thanks for the reply.
I confirmed /dev/video0 with v4l2-ctl --list-devices and with cheese software. Also i checked by unplugging.

Power supply is 5v 2A micro usb charger.

Also does it require fan for jetson-interface projects? As i can see, the temerature goes above 49 degrees and gets shut down while using one of the projects.

Here is the gst-camera log file.
It is showing only a black screen.
gst-camera.log (6.8 KB)

It is likely that your power supply is not capable of delivering the sustained, stable current needed @ 5V. Look to this thread on power supplies to see validated power adapters which work well under load.

In the meantime, you can try changing your Nano from 10W mode (which is the default) to 5W mode by running this command from terminal after booting up before launching the inferencing programs:

$ sudo nvpmodel -m 1

See this post for another similar case.

hello

when i run ./detectnet-camera with my nvidia xavier and the logitech c930e.
i have this issue.

detectnet-camera: failed to capture frame
detectnet-camera: failed to convert from NV12 to RGBA
detectNet::Detect( 0x(nil), 1280, 720 ) -> invalid parameters
[cuda] cudaNormalizeRGBA((float4*)imgRGBA, make_float2(0.0f, 255.0f), (float4*)imgRGBA, make_float2(0.0f, 1.0f), camera->GetWidth(), camera->GetHeight())
[cuda] invalid device pointer (error 17) (hex 0x11)
[cuda] /home/nvidia/jetson-inference/detectnet-camera/detectnet-camera.cpp:247

help please !!

What does this command actually do.? sudo nvpmodel -m 1?

My nano was crashing while running the jetson inference demos but after running the above command, its now stable.

What this command does is set the board into 5W mode (the default mode is 10W). 5W mode reduces the maximum clock speeds and disables 2 of the 4 CPU cores.

What it means is that your power supply is not able to reliably supply 10W. If you get one of the recommended power supplies from this thread, you shouldn’t have the problem any more and be able to run the demos with full performance in 10W mode.