jetson-io.py and config-by-pin.py can't be used on Jetson Nano

After program nv-jetson-nano-sd-card-image-r32.3.1.zip to tf card, and boot jetson nano board up.
When I want to try jetson-io.py by following ‘Configuring the 40-pin Expansion Header’. I see below symptom.

  1. Nothing happens when run jetson-io.py
    sudo /opt/nvidia/jetson-io/jetson-io.py

2.config-by-pin.py and config-by-function.py reports below errors.
yisp@yisp-desktop:~$ sudo /opt/nvidia/jetson-io/config-by-pin.py -p 5
[sudo] password for yisp:
Traceback (most recent call last):
File “/opt/nvidia/jetson-io/config-by-pin.py”, line 51, in
main()
File “/opt/nvidia/jetson-io/config-by-pin.py”, line 34, in main
jetson = board.Board()
File “/opt/nvidia/jetson-io/Jetson/board.py”, line 149, in init
self.dtb = _board_get_dtb(self.compat, self.model, dtbdir)
File “/opt/nvidia/jetson-io/Jetson/board.py”, line 88, in _board_get_dtb
raise RuntimeError(“No DTB found for %s!” % model)
RuntimeError: No DTB found for NVIDIA Jetson Nano Developer Kit!

yisp@yisp-desktop:~ yisp@yisp-desktop:~ sudo /opt/nvidia/jetson-io/config-by-function.py -l all
Traceback (most recent call last):
File “/opt/nvidia/jetson-io/config-by-function.py”, line 92, in
main()
File “/opt/nvidia/jetson-io/config-by-function.py”, line 76, in main
jetson = board.Board()
File “/opt/nvidia/jetson-io/Jetson/board.py”, line 149, in init
self.dtb = _board_get_dtb(self.compat, self.model, dtbdir)
File “/opt/nvidia/jetson-io/Jetson/board.py”, line 88, in _board_get_dtb
raise RuntimeError(“No DTB found for %s!” % model)
RuntimeError: No DTB found for NVIDIA Jetson Nano Developer Kit!

The board serial is
P3448; 180-13448-DAAA-A02
P3450; 180-13449-DAAF-A02

Does your Nano is EMMC version?
That’s know issue like https://devtalk.nvidia.com/default/topic/1070924 report.

What’s purpose you need to run jetson-io?

Hello!

This is a known issue with the current SD card image (which we are working to fix). For now, please try the following workaround …

https://devtalk.nvidia.com/default/topic/1068583/jetson-nano/jetpack-4-3-l4t-r32-3-1-released/post/5413341/#5413341

Thanks
Jon

Thanks a lot. This works.

Hi, Shane
Thanks a lot. My problem has been solved by making a copy of dtb files into /boot/dtb.
For your questions:
1. Currently, I am using etcher to burn a tf card. and let the board booted from tf card.
2. I want to enable SPI0.0,SPI0.1,SPI1.0,SPI1.1. I will have four spi devices that connected to jetson nano board.

Hello!

I believe that by default only two spidevs are exposed on Jetson Nano via the /dev/spidevX.Y interface. However, someone has managed to update the Nano device-tree to get all chip-selects for all SPI interfaces exposed on the 40-pin header to work. See …

https://devtalk.nvidia.com/default/topic/1068583/jetson-nano/jetpack-4-3-l4t-r32-3-1-released/post/5422636/#5422636

We are working to enabled all spi0.0, spi0.1, spi1.0 and spi1.1 in future releases so that no manual update of the DTB will be necessary.

Regards,
Jon