Can't find DTB file on Jetson Nano Dev Kit A02

I have a official Nvidia jetson nano dev kit A02 (From 2019 with only 1 csi-connector). It’s booted from SD-card with and image:“jetson-nano-jp461-sd-card-image”. It has never been flashed with SDK manager. (I have no Ubuntu machine to use)

I’m trying to use to switch the CSI-connector to work with IMX477 cameras(specifically the RPi Hq canera).
But run with sudo produces no output. If I instead try to run ´´´sudo /opt/nvidia/jetson-io/´´´ I get the following error:

jet@jetson:/boot/dtb$ sudo /opt/nvidia/jetson-io/
[sudo] password for jet:
Traceback (most recent call last):
  File "/opt/nvidia/jetson-io/", line 84, in <module>
  File "/opt/nvidia/jetson-io/", line 39, in main
    jetson = board.Board()
  File "/opt/nvidia/jetson-io/Jetson/", line 222, in __init__
    self.dtb = _board_get_dtb(self.compat, self.model, dtbdir)
  File "/opt/nvidia/jetson-io/Jetson/", line 114, in _board_get_dtb
    raise RuntimeError("No DTB found for %s!" % model)
RuntimeError: No DTB found for NVIDIA Jetson Nano Developer Kit!

This issue is mentioned in an old thread from 2019 : JetPack 4.3 - L4T R32.3.1 released - #22 by jonathanh That has a potential solution that I have not tried since it claims the issue should be solved in future releases. I have read many threads from the last 10 days and multiple have problems with or i2c, SPI. and CSI cameras. Is perhaps the Latest SD-card image bad?

jet@jetson:~$ cat /sys/firmware/devicetree/base/compatible
jet@jetson:~$ fdtget /boot/dtb/*.dtb / compatible
nvidia,p3449-0000-b00+p3448-0000-b00 nvidia,jetson-nano nvidia,tegra210

I attach below ‘dmesg’ log and ‘ls’ output of /boot and /boot/dtb :
dmesg_log_after_reboot.txt (56.5 KB)
jetson-io_error.txt (4.3 KB)

Could you try the latest Jetpack 4.6.3? It would be great if you can upgrade to latest release and try.


The device is already on Jetpack 4.6.3. I got that by using “sudo apt update” and “sudo apt upgrade” which I did just after setting it up on first boot.

jet@jetson:~$ sudo apt-cache show nvidia-jetpack
Package: nvidia-jetpack
Version: 4.6.3-b17
Architecture: arm64
Maintainer: NVIDIA Corporation

But I solved my problem this way:

  1. Copy “*a02.dtb” into /boot/dtb
  2. Run Configure it for imx477. Save configuration but don’t reboot.
  3. Remove “*a02.dtb” from /boot/dtb
  4. Reboot Jetson Nano Devkit.
[    0.607057] Linux video capture interface: v2.00
[    1.263159] imx477 6-001a: tegracam sensor driver:imx477_v2.0.6
[    1.721885] vi subdev imx477 6-001a bound

And it works, tested with nvgstcapture-1.0 👍😀

(Note to anyone finding this in the future, trying to use a Raspberry HQ camera on A02 dev kit. It only works because I have a logic level shifter board in between the camera and the Jetson, built according to this guide: Raspberry Pi HQ Camera in Jetson Nano - #59 by nvidia134 )

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.