JETSON-IO python command ,NO GPIO OPTION,picture

when i run sudo /opt/nvidia/jetson-io/

it only show one option

my basic info:

jetpack4.6.1(use SDK manager install),i also try 4.6.2,same result

I want to use CAN MCP2515 module,so i need use the “” set spi ,and check MCP2515.


jetson nano is 4GB ,and EMMC 16G ,and i dont know my hardware is A02 or B00?

hello 434379124,

Jetson-IO is for development purpose use only, for Nano series, Jetson-IO only enable for Module with SD version.
since Module with eMMC version is for production purpose, the official procedure is to use pinmux table to make any changes.

Are there any instructions for installing the CAN bus module (MCP2515 SPI) for the EMMC version jetson nano configuration? I don’t know pinmux, DTS, etc. yet, but I can learn, need a proper documentation, so that I don’t take a detour, thank you…

hello 434379124,

here’s developer guide for the Pinmux Changes. please download pinmux spreadsheets to have customization.
please also check similar discussion threads for reference, such as… Topic 112271, or Topic 164523.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.