Jetson Nano 2GB usb connects for a few seconds when booting recovery and then disconnects

[24795.859569] usb 3-4: new high-speed USB device number 27 using xhci_hcd
[24796.012214] usb 3-4: New USB device found, idVendor=0955, idProduct=7f21, bcdDevice= 1.02
[24796.012224] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[24796.012227] usb 3-4: Product: APX
[24796.012230] usb 3-4: Manufacturer: NVIDIA Corp.
[24801.254370] usb 3-4: USB disconnect, device number 27

Basically the title. This does not allow me to actually flash the board with the docker version of sdkmanager. Currently running PopOS 22.04 with sdkmanager:1.9.3.10904-Ubuntu_18.04 docker container. pin 9 and 10 on J12 are currently jumped to allow for recovery mode, however I seem to think recovery mode does not occur since my UART adapter does not dump any logs into my serial console. Anyone able to help with this?

Non-recovery mode currently ends with the following (hence I want to flash the board to fix it):

[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.151] RamCode = 1
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x429f5
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful 
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.199] Lp0 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.205] BpmpFw Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.211] GSC1 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.216] Resize the SecureOs Carveout to 0x00100000
[0000.221] GSC2 Carveout Base=0x00000000ff900000 Size=0x00100000
[0000.227] GSC4 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.233] GSC5 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.238] GSC3 Carveout Base=0x00000000bf800000 Size=0x00200000
[0000.244] RamDump Carveout Base=0x0000000000000000 Size=0x00000000
[0000.250] Platform-DebugCarveout: 0
[0000.253] Nck Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.259] Non secure mode, and RB not enabled.
[0000.263] BoardID = 3448, SKU = 0x3
[0000.267] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.270] Nano-SD: checking PT table on QSPI ...
[0000.275] Initialize FailControl
[0000.278] Read PT from (2:0)
[0000.308] PT crc32 and magic check passed.
[0000.312] Using BFS PT to query partitions 
[0000.318] Loading Tboot-CPU binary
[0000.346] Verifying TBC in OdmNonSecureSBK mode
[0000.357] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.364] Bootloader downloaded successfully.
[0000.369] Downloaded Tboot-CPU binary to 0xa0000258
[0000.374] MAX77620_GPIO5 configured
[0000.377] CPU power rail is up
[0000.380] CPU clock enabled
[0000.384] Performing RAM repair
[0000.386] Updating A64 Warmreset Address to 0xa00002e9
[0000.391] BoardID = 3448, SKU = 0x3
[0000.395] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.398] Nano-SD: checking PT table on QSPI ...
[0000.403] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.409] Loading NvTbootBootloaderDTB
[0000.475] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode
[0000.545] Bootloader DTB Load Address: 0x83000000
[0000.549] BoardID = 3448, SKU = 0x3
[0000.552] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.556] Nano-SD: checking PT table on QSPI ...
[0000.561] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.567] Loading NvTbootKernelDTB
[0000.633] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode
[0000.702] Kernel DTB Load Address: 0x83100000
[0000.706] BoardID = 3448, SKU = 0x3
[0000.709] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.713] Nano-SD: checking PT table on QSPI ...
[0000.717] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.725] Loading cboot binary
[0000.841] Verifying EBT in OdmNonSecureSBK mode
[0000.883] Bootloader load address is 0x92c00000, entry address is 0x92c00258
[0000.890] Bootloader downloaded successfully.
[0000.894] BoardID = 3448, SKU = 0x3
[0000.897] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.901] Nano-SD: checking PT table on QSPI ...
[0000.905] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.912] PT: Partition NCT NOT found ! 
[0000.915] Warning: Find Partition via PT Failed
[0000.920] Next binary entry address: 0x92c00258 
[0000.924] BoardId: 3448
[0000.929] Overriding pmu board id with proc board id
[0000.933] Display board id is not available 
[0000.938] No Bpmp FW loaded
[0000.940] Not loading WB0 as no bpmp/sc7entry fw
[0000.945] Set NvDecSticky Bits
[0000.948] GSC2 address ff93fffc value c0edbbcc
[0000.954] GSC MC Settings done
[0000.957] BoardID = 3448, SKU = 0x3
[0000.961] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.964] Nano-SD: checking PT table on QSPI ...
[0000.969] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.976] TOS Image length 53680
[0000.979]  Monitor size 53680
[0000.982]  OS size 0
[0000.997] Secure Os AES-CMAC Verification Success!
[0001.001] TOS image cipher info: plaintext
[0001.005] Loading and Validation of Secure OS Successful
[0001.021] NvTbootPackSdramParams: start. 
[0001.026] NvTbootPackSdramParams: done. 
[0001.030] Tegraboot started after 52343 us
[0001.034] Basic modules init took 955301 us
[0001.038] Sec Bootdevice Read Time = 12 ms, Read Size = 61 KB
[0001.043] Sec Bootdevice Write Time = 0 ms, Write Size = 0 KB
[0001.049] Next stage binary read took 11286 us
[0001.053] Carveout took -69912 us
[0001.056] CPU initialization took 106075 us
[0001.060] Total time taken by TegraBoot 1002750 us

[0001.065] Starting CPU & Halting co-processor 

64NOTICE:  BL31: v1.3(release):f9bf1e1
NOTICE:  BL31: Built : 21:16:40, Jun  8 2023
ERROR:   Error initializing runtime service trusty_fast
[0001.187] RamCode = 1
[0001.197] LPDDR4 Training: found 4 entries (2 nominal, 2 derated)
[0001.202] EMC Training (SRC-freq: 204000; DST-freq: 1600000)
[0001.215] EMC Training Successful
[0001.218] EMC Training (SRC-freq: 204000; DST-freq: 1600000)
[0001.231] EMC Training Successful
[0001.234] 408000 not found in DVFS table
[0001.274] RamCode = 1
[0001.280] DT Write: emc-table@204000 succeeded
[0001.287] DT Write: emc-table@1600000 succeeded
[0001.295] DT Write: emc-table-derated@204000 succeeded
[0001.304] DT Write: emc-table-derated@1600000 succeeded
[0001.309] LPDDR4 Training: Write DT: Number of tables = 4
[0001.349] 
[0001.350] Debug Init done
[0001.353] Marked DTB cacheable
[0001.356] Bootloader DTB loaded at 0x83000000
[0001.360] Marked DTB cacheable
[0001.363] Kernel DTB loaded at 0x83100000
[0001.367] DeviceTree Init done
[0001.382] Pinmux applied successfully
[0001.387] gicd_base: 0x50041000
[0001.390] gicc_base: 0x50042000
[0001.393] Interrupts Init done
[0001.398] Using base:0x60005090 & irq:208 for tick-timer
[0001.403] Using base:0x60005098 for delay-timer
[0001.407] platform_init_timer: DONE
[0001.411] Timer(tick) Init done
[0001.415] osc freq = 38400 khz
[0001.419] 
[0001.420] Welcome to L4T Cboot
[0001.423] 
[0001.424] Cboot Version: 00.00.2018.01-t210-acb23272
[0001.429] calling constructors
[0001.432] initializing heap
[0001.435] initializing threads
[0001.438] initializing timers
[0001.441] creating bootstrap completion thread
[0001.445] top of bootstrap2()
[0001.448] CPU: ARM Cortex A57
[0001.451] CPU: MIDR: 0x411FD071, MPIDR: 0x80000000
[0001.455] initializing platform
[0001.464] Manufacturer: MF = 0xc2, ID MSB = 0x25
[0001.469] ID LSB = 0x36, ID-CFI len = 194 bytes
[0001.473] Macronix QSPI chip present
[0001.477] SPI device register
[0001.479] init boot device
[0001.482] allocating memory for boot device(SPI)
[0001.487] registering boot device
[0001.495] QSPI bdev is already initialized
[0001.499] Enable APE clock
[0001.502] Un-powergate APE partition
[0001.505] of_register: registering tegra_udc to of_hal
[0001.510] of_register: registering inv20628-driver to of_hal
[0001.516] of_register: registering ads1015-driver to of_hal
[0001.521] of_register: registering lp8557-bl-driver to of_hal
[0001.527] of_register: registering bq2419x_charger to of_hal
[0001.533] of_register: registering bq27441_fuel_gauge to of_hal
[0001.546] gpio framework initialized
[0001.549] of_register: registering tca9539_gpio to of_hal
[0001.555] of_register: registering tca9539_gpio to of_hal
[0001.560] of_register: registering i2c_bus_driver to of_hal
[0001.566] of_register: registering i2c_bus_driver to of_hal
[0001.571] of_register: registering i2c_bus_driver to of_hal
[0001.577] pmic framework initialized
[0001.580] of_register: registering max77620_pmic to of_hal
[0001.586] regulator framework initialized
[0001.590] of_register: registering tps65132_bl_driver to of_hal
[0001.595] initializing target
[0001.602] gpio_driver_register: register 'tegra_gpio_driver' driver
[0001.611] board ID = D78, board SKU = 3
[0001.614] Skipping Z3!
[0001.620] fixed regulator driver initialized
[0001.643] initializing OF layer
[0001.646] NCK carveout not present
[0001.649] Skipping dts_overrides
[0001.653] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.672] I2C Bus Init done
[0001.675] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.686] I2C Bus Init done
[0001.688] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.700] I2C Bus Init done
[0001.702] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.714] I2C Bus Init done
[0001.716] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.728] I2C Bus Init done
[0001.730] of_children_init: Ops found for compatible string maxim,max77620
[0001.741] max77620_init using irq 118
[0001.746] register 'maxim,max77620' pmic
[0001.751] gpio_driver_register: register 'max77620-gpio' driver
[0001.757] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.768] I2C Bus Init done
[0001.772] NCK carveout not present
[0001.784] Find /i2c@7000c000's alias i2c0
[0001.787] get eeprom at 1-a0, size 256, type 0
[0001.798] Find /i2c@7000c500's alias i2c2
[0001.802] get eeprom at 3-a0, size 256, type 0
[0001.806] get eeprom at 3-ae, size 256, type 0
[0001.810] pm_ids_update: Updating 1,a0, size 256, type 0
[0001.816] I2C slave not started
[0001.819] I2C write failed
[0001.821] Writing offset failed
[0001.824] eeprom_init: EEPROM read failed
[0001.828] pm_ids_update: eeprom init failed
[0001.832] pm_ids_update: Updating 3,a0, size 256, type 0
[0001.862] pm_ids_update: The pm board id is 3448-0003-400
[0001.869] Adding plugin-manager/ids/3448-0003-400=/i2c@7000c500:module@0x50
[0001.878] pm_ids_update: pm id update successful
[0001.882] pm_ids_update: Updating 3,ae, size 256, type 0
[0001.912] pm_ids_update: The pm board id is 3542-0000-201
[0001.919] Adding plugin-manager/ids/3542-0000-201=/i2c@7000c500:module@0x57
[0001.927] pm_ids_update: pm id update successful
[0001.958] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0001.964] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0001.972] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0001.978] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0001.986] updating /chosen/nvidia,ethernet-mac node 48:b0:2d:2e:91:54
[0001.993] Plugin Manager: Parse ODM data 0x000a4000
[0002.005] shim_cmdline_install: /chosen/bootargs: earlycon=uart8250,mmio32,0x70006000 
[0002.022] Find /i2c@7000c000's alias i2c0
[0002.026] get eeprom at 1-a0, size 256, type 0
[0002.036] Find /i2c@7000c500's alias i2c2
[0002.040] get eeprom at 3-a0, size 256, type 0
[0002.044] get eeprom at 3-ae, size 256, type 0
[0002.048] pm_ids_update: Updating 1,a0, size 256, type 0
[0002.054] I2C slave not started
[0002.057] I2C write failed
[0002.059] Writing offset failed
[0002.062] eeprom_init: EEPROM read failed
[0002.066] pm_ids_update: eeprom init failed
[0002.071] pm_ids_update: Updating 3,a0, size 256, type 0
[0002.101] pm_ids_update: The pm board id is 3448-0003-400
[0002.107] Adding plugin-manager/ids/3448-0003-400=/i2c@7000c500:module@0x50
[0002.114] pm_ids_update: pm id update successful
[0002.119] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.149] pm_ids_update: The pm board id is 3542-0000-201
[0002.155] Adding plugin-manager/ids/3542-0000-201=/i2c@7000c500:module@0x57
[0002.162] pm_ids_update: pm id update successful
[0002.193] Add serial number:1424020009333 as DT property
[0002.201] Applying platform configs
[0002.208] platform-init is not present. Skipping
[0002.213] calling apps_init()
[0002.218] Couldn't find GPT header
[0002.223] Proceeding to Cold Boot
[0002.226] starting app android_boot_app
[0002.230] Device state: unlocked
[0002.233] display console init
[0002.243] could not find regulator
[0002.266] hdmi cable not connected
[0002.269] isDT entry for leds-pwm not found
_[0002.277] hdmi_needed: HDMI not connected, returning false
[0002.283] hdmi is not connected
[0002.286] sor0 is not supported
[0002.289] display_console_init: no valid display out_type
[0002.298] subnode volume_up is not found !
[0002.302] subnode back is not found !
[0002.305] subnode volume_down is not found !
[0002.309] subnode menu is not found !
[0002.313] Gpio keyboard init success
[0002.393] found decompressor handler: lz4-legacy
[0002.408] decompressing blob (type 1)...
[0002.472] display_resolution: No display init
[0002.477] Failed to retrieve display resolution
[0002.481] Could not load/initialize BMP blob...ignoring
[0002.486] -------> se_aes_verify_sbk_clear: 747
[0002.491] se_aes_verify_sbk_clear: Error
[0002.495] SE operation failed
[0002.498] bl_battery_charging: connected to external power supply
[0002.508] display_console_ioctl: No display init
[0002.512] switch_backlight failed
[0002.518] device_query_partition_size: failed to open partition spiflash0:MSC !
[0002.526] MSC Partition not found
[0002.532] device_query_partition_size: failed to open partition spiflash0:USP !
[0002.539] USP partition read failed!
[0002.543] blob_init: blob-partition USP header read failed
[0002.548] android_boot Unable to update recovery partition
[0002.554] kfs_getpartname: name = LNX
[0002.557] Loading kernel from LNX
[0002.567] Found 19 BFS partitions in "spiflash0"
[0002.891] load kernel from storage
[0002.896] decompressor handler not found
[0003.166] Successfully loaded kernel and ramdisk images
[0003.171] board ID = D78, board SKU = 3
[0003.176] sdmmc node status = okay
[0003.179] sdcard instance = 0
[0003.182] sdmmc cd-inverted
[0003.185] sdcard gpio handle 0x5a
[0003.188] sdcard gpio pin 0xc9
[0003.191] sdcard gpio flags 0x0
[0003.194] vmmc-supply 0x9a
[0003.196] cd_gpio_pin = 201
[0003.199] pin_state = 0
[0003.201] Found sdcard
[0003.204] SD-card IS present ...
[0003.207] load_and_boot_kernel: SD card detected OK
[0003.213] display_resolution: No display init
[0003.217] Failed to retrieve display resolution
[0003.222] bmp blob is not loaded and initialized
[0003.226] Failed to display boot-logo
[0003.230] NCK carveout not present
[0003.233] Skipping dts_overrides
[0003.236] NCK carveout not present
[0003.248] Find /i2c@7000c000's alias i2c0
[0003.252] get eeprom at 1-a0, size 256, type 0
[0003.262] Find /i2c@7000c500's alias i2c2
[0003.266] get eeprom at 3-a0, size 256, type 0
[0003.270] get eeprom at 3-ae, size 256, type 0
[0003.275] pm_ids_update: Updating 1,a0, size 256, type 0
[0003.280] I2C slave not started
[0003.283] I2C write failed
[0003.286] Writing offset failed
[0003.289] eeprom_init: EEPROM read failed
[0003.293] pm_ids_update: eeprom init failed
[0003.297] pm_ids_update: Updating 3,a0, size 256, type 0
[0003.327] pm_ids_update: The pm board id is 3448-0003-400
[0003.334] Adding plugin-manager/ids/3448-0003-400=/i2c@7000c500:module@0x50
[0003.342] pm_ids_update: pm id update successful
[0003.347] pm_ids_update: Updating 3,ae, size 256, type 0
[0003.377] pm_ids_update: The pm board id is 3542-0000-201
[0003.383] Adding plugin-manager/ids/3542-0000-201=/i2c@7000c500:module@0x57
[0003.391] pm_ids_update: pm id update successful
[0003.422] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0003.428] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0003.436] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0003.442] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0003.451] updating /chosen/nvidia,ethernet-mac node 48:b0:2d:2e:91:54
[0003.457] Plugin Manager: Parse ODM data 0x000a4000
[0003.469] shim_cmdline_install: /chosen/bootargs: earlycon=uart8250,mmio32,0x70006000 
[0003.478] Add serial number:1424020009333 as DT property
[0003.486] Updated bpmp info to DTB
[0003.491] Updated initrd info to DTB
[0003.494] "proc-board" doesn't exist, creating 
[0003.500] Updated board info to DTB
[0003.504] "pmu-board" doesn't exist, creating 
[0003.510] Updated board info to DTB
[0003.513] "display-board" doesn't exist, creating 
[0003.519] Updated board info to DTB
[0003.522] "reset" doesn't exist, creating 
[0003.527] Updated reset info to DTB
[0003.530] display_console_ioctl: No display init
[0003.535] display_console_ioctl: No display init
[0003.539] display_console_ioctl: No display init
[0003.544] Cmdline: tegraid=21.1.2.0.0 ddr_die=2048M@2048M section=256M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,4 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 core_edp_mv=1125 core_edp_ma=4000 gpt 
[0003.576] DTB cmdline: earlycon=uart8250,mmio32,0x70006000 
[0003.582] boot image cmdline: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 
[0003.595] Updated bootarg info to DTB
[0003.598] Adding uuid 00000001644577822000000004000480 to DT
[0003.604] Adding eks info 0 to DT
[0003.610] WARNING: Failed to pass NS DRAM ranges to TOS, err: -7
[0003.616] Updated memory info to DTB
[0003.626] set vdd_core voltage to 1125 mv
[0003.629] setting 'vdd-core' regulator to 1125000 micro volts
[0003.635] Found secure-pmc; disable BPMP


U-Boot 2020.04-g4335beb (Jun 08 2023 - 21:16:43 -0700)

SoC: tegra210
Model: NVIDIA Jetson Nano 2GB Developer Kit
Board: NVIDIA P3541-0000
DRAM:  2 GiB
MMC:   sdhci@700b0000: 1, sdhci@700b0600: 0
Loading Environment from SPI Flash... SF: Detected mx25u3235f with page size 256 Bytes, erase size 4 KiB, total 4 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
Hit any key to stop autoboot:  1 


Devices won’t output any log when it’s force recovery mode without being currently flashed, so this is expected.

What do issues do hit with SDK Manager now?
Have you tried with other flashing cables?

I have tried a usb-a to micro-b cable and a type-c to micro-b. Same stuff, it would appear in dmesg and immediately disconnect, like mentioned at the top.

Then how about this?

Well in short it pre-downloads the sdk as normal, creates images etc but I can’t flash the board because it does not see any connected boards. Running a separate command to show connected devices through sdkmanager yielded no connected devices. So it clearly is unable to see the usb connection. I am confident the ports work fine because a) I can see my phone if I connect it and b) I installed PopOS just a few weeks ago via the usb-a port I tried for this. The cables are both new as well. My only theory right now is that the Jetson nano usb driver for Ubuntu 22.04 and related distros is either broken or non functional, but I don’t know if that theory has any substance.

Try the manual flashing commands on your PopOS host PC instead of Docker:
https://docs.nvidia.com/jetson/archives/l4t-archived/l4t-3274/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/quick_start.html#

It should theoretically work as PopOS is also based on Ubuntu, and share package repositories.
It if still fails, get another host PC and try again, or RMA the device.

Thanks, will do.

So I still cannot get it to do anything, cant get into recovery as it just disconnects from usb device mode 5 seconds after power is supplied. Otherwise the bootup has changed a bit. Now shows the following:

0000.125] [L4T TegraBoot] (version 00.00.2018.01-l4t-b1625959)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.151] RamCode = 1
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x429f5
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful 
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.199] Lp0 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.205] BpmpFw Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.211] GSC1 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.216] Resize the SecureOs Carveout to 0x00100000
[0000.221] GSC2 Carveout Base=0x00000000ff900000 Size=0x00100000
[0000.227] GSC4 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.233] GSC5 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.238] GSC3 Carveout Base=0x00000000bf800000 Size=0x00200000
[0000.244] RamDump Carveout Base=0x0000000000000000 Size=0x00000000
[0000.250] Platform-DebugCarveout: 0
[0000.253] Nck Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.259] Non secure mode, and RB not enabled.
[0000.263] BoardID = 3448, SKU = 0x3
[0000.267] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.270] Nano-SD: checking PT table on QSPI ...
[0000.275] Initialize FailControl
[0000.278] Read PT from (2:0)
[0000.308] PT crc32 and magic check passed.
[0000.312] Using BFS PT to query partitions 
[0000.318] Loading Tboot-CPU binary
[0000.346] Verifying TBC in OdmNonSecureSBK mode
[0000.357] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.364] Bootloader downloaded successfully.
[0000.369] Downloaded Tboot-CPU binary to 0xa0000258
[0000.374] MAX77620_GPIO5 configured
[0000.377] CPU power rail is up
[0000.380] CPU clock enabled
[0000.384] Performing RAM repair
[0000.386] Updating A64 Warmreset Address to 0xa00002e9
[0000.391] BoardID = 3448, SKU = 0x3
[0000.395] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.398] Nano-SD: checking PT table on QSPI ...
[0000.403] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.409] Loading NvTbootBootloaderDTB
[0000.476] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode
[0000.687] Bootloader DTB Load Address: 0x83000000
[0000.692] BoardID = 3448, SKU = 0x3
[0000.695] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.699] Nano-SD: checking PT table on QSPI ...
[0000.703] NvTbootFailControlDoFailover: No failover; Continuing ...
[0000.710] Loading NvTbootKernelDTB
[0000.776] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode
[0000.987] Kernel DTB Load Address: 0x83100000
[0000.991] BoardID = 3448, SKU = 0x3
[0000.994] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.998] Nano-SD: checking PT table on QSPI ...
[0001.003] NvTbootFailControlDoFailover: No failover; Continuing ...
[0001.011] Loading cboot binary
[0001.127] Verifying EBT in OdmNonSecureSBK mode
[0001.341] Bootloader load address is 0x92c00000, entry address is 0x92c00258
[0001.348] Bootloader downloaded successfully.
[0001.352] BoardID = 3448, SKU = 0x3
[0001.356] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0001.359] Nano-SD: checking PT table on QSPI ...
[0001.364] NvTbootFailControlDoFailover: No failover; Continuing ...
[0001.371] PT: Partition NCT NOT found ! 
[0001.375] Warning: Find Partition via PT Failed
[0001.379] Next binary entry address: 0x92c00258 
[0001.383] BoardId: 3448
[0001.388] Overriding pmu board id with proc board id
[0001.393] Display board id is not available 
[0001.397] No Bpmp FW loaded
[0001.400] Not loading WB0 as no bpmp/sc7entry fw
[0001.404] Set NvDecSticky Bits
[0001.408] GSC2 address ff93fffc value c0edbbcc
[0001.414] GSC MC Settings done
[0001.417] BoardID = 3448, SKU = 0x3
[0001.420] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0001.424] Nano-SD: checking PT table on QSPI ...
[0001.428] NvTbootFailControlDoFailover: No failover; Continuing ...
[0001.436] TOS Image length 53680
[0001.439]  Monitor size 53680
[0001.442]  OS size 0
[0001.467] Secure Os AES-CMAC Verification Success!
[0001.471] TOS image cipher info: plaintext
[0001.475] Loading and Validation of Secure OS Successful
[0001.505] NvTbootPackSdramParams: start. 
[0001.510] NvTbootPackSdramParams: done. 
[0001.514] Tegraboot started after 52339 us
[0001.518] Basic modules init took 1426502 us
[0001.522] Sec Bootdevice Read Time = 12 ms, Read Size = 61 KB
[0001.527] Sec Bootdevice Write Time = 0 ms, Write Size = 0 KB
[0001.533] Next stage binary read took 11286 us
[0001.537] Carveout took -70723 us
[0001.540] CPU initialization took 131182 us
[0001.544] Total time taken by TegraBoot 1498247 us

[0001.549] Starting CPU & Halting co-processor 

Anything you are able to suggest on the matter? Judging by the last few logs, I am starting to thing the board is dead.

Then please RMA the device.

Yeah, bout that, the device was bought used so. Guess I am boned lol.

Contact our customer support and they will tell you whether it’s qualified for RMA.

Okay, I will be sure to contact customer support in the coming days.

вт, 11 июн. 2024 г. в 06:43, Dave Yu via NVIDIA Developer Forums <notifications@nvidia.discoursemail.com>: