Jetson Nano 2GB VNV headless VNC Connection refused Computer


I am facing an issue with Jetson Nano 2GB.I use headless setup
I have configured VNC as per instructions given in VNC-readme but when tried to connect it throws an error saying connection refused by computer.I can connect using SSH to Jetson.I am not using any HDMI Monitor.Can you please help to resolve issue

Could you help check if this page can help?

I alreday used those steps but still facing issue.Kindly help to resolve it

Which kind of OS does your client runs?
I just tried with my ubuntu host and it can login into device.
Did you set a password for your vnc connection?

Client-side i tried with both ubuntu and windows.
I set a password as per VNC-readme document
But i get connection refused message before getting the password prompt in client machine

I don’t know about the VNC side of things, but typically when the message is “connection refused” it means that the computer you are trying to talk to does not have anything running on that port. If the computer you are trying to talk to has a firewall blocking that port, then it might also say “connection refused”, but the default for the Jetson won’t be with a firewall. Odds are that something related to the system being communicated with is not actually running VNC…at least not with the port and protocol you expect.

I noticed VNC works when HDMI Monitor is Powered On and will not work if HDMI monitor is disconnected/powered off. Is there a way to do VNC without connecting HDMI Monitor

There is, but I could not tell you the method (it is something I have not set up). Basically, a client requires a server to be running somewhere. The client won’t care if the server talks to a real monitor, or to a virtual server which pretends to have a monitor. There would be some sort of virtual server you could set up. Anyone here know what needs to be installed for him to use VNC without the actual monitor?

this one will work without hdmi monitoe attached