Jetson nano dev kit stuck in recovery mode

Hi,

I’ve recently receive some jetson nano labelled as “Jetson Nano developer kit V3”, which turns out to be the B01 varient of the Jetson Nano dev kit but has the boot firmware moved to the QSPI flash as mentioned in R32.5.1 release note (L4T 32.5 Archive | NVIDIA Developer).

The main issue I have is that the os that we’re using is still in 32.4.4 (we’re using BalenaOS balenaOS - Run Docker containers on embedded IoT devices) which was build on Yocto. Since the u-boot is now moved towards the qspi flash for this specific “V3” dev kit from the vendor, I attempted to flash revert the qspi firmware back to R32.4.4.

I’ve tried to flash the qspi using R32.4.4 using the ./flash.sh script included in the BSP archive (BSP archive available here: https://developer.nvidia.com/embedded/L4T/r32_Release_v4.4/r32_Release_v4.4-GMC3/T210/Tegra210_Linux_R32.4.4_aarch64.tbz2). The steps I did was:

  • remove sd card
  • place jumper between GND and FC REC
  • remove jumper on J48
  • plug in Micro USB cable to Nano and host
  • lsusb return Nvidia USB receiver
  • run sudo ./flash.sh -k LNX jetson-nano-qspi-sd mmcblk0p1
  • flash was successful
  • remove micro USB
  • remove jumper between GND and FC REC
  • put jetpack image sd card in
  • attach to console debug output
  • plug in micro usb to power on device again
  • no logs from console debug
  • checked host lsusb and Nvidia USB receive device still exist

I’ve tried this on 2 separate ‘V3’ nano and are getting the same result. I’ve looked around the forum and it seems like some other people are facing this issue as well, however most of it was pointing to a hardware error.

I felt like I’m doing something wrong and is causing the device to stuck in the recovery mode.

Any help would be appreciated, thanks in advance!

flash.sh output
uboot-flash-output.txt (13.4 KB)

  1. Learn to dump the log from uart. So that you can know whether the board is stuck in rcm or not. Honestly speaking, I don’t think it gets stuck in RCM.
  1. I think the correct way is you find a empty sdcard, plug it to your board, flash your whole board with jetpack4.4 from sdkmanager. And then move to your current sdcard with Yocto installed.
    The problem of your current method is you just install “uboot”. But we do have other bootloader components.
    You should configure the whole board back to jp4.4 environment again.

Hey @WayneWWW ,

Thanks for the reply, I did tried to get the log from uart but nothing was logged. What’s rcm?

As for your suggestion to flash jp4.4 from the sdkmanager, that actually fixes my issue and now the device is able boot up correctly. Thanks!

RCM means recovery mode.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.