nano cannot put into recovery mode

hello, Recently, when I used nano to update the device tree of spi, I connected the hardware according to the instructions. The terminal prompted me that I could not find the device or the device did not enter the recovery mode. I could not find the reason. Please give me your advice.thank you very much.

Hi,

Are you able to see the device from host with lsusb command?

thank you for you reply,I tried and this is what I saw, and I don’t know if I can find the device.

The device is in recovery mode as the “Nvidia corp” is shown in the lsusb.

What error did you see during flash?

As shown in the picture。

I think the usb connection is ok, otherwise it can’t print nvidia when use lsusb command, but I still can’t update it!

Are you using a virtual machine?

No, the host is installed ubuntu18.04.

According to the picture, the device is powered by the power jack instead of usb, right?

If so, could you try different usb cable?

Yes, the power is supplied by dc power. I tried to replace a mini-usb cable yesterday, but the result is still the same. I really have no idea.

Could you share your flash command?

1 download JetsonNano_DT_SPI_master.zip on PC,it isubuntu18.04.
2 cd JetsonNano_DT_SPI_master/
3 ./run.sh

I refer to this Chinese website: http://www.waveshare.net/study/article-887-1.html
thank you very much

Could you also try the official sdkmanager?

Is there any questions use the flash command? I’ll install the SDK later and try it.

In the link your shared, the flash command is:
sudo ./flash.sh --no-systemimg -k DTB jetson-nano-qspi-sd mmcblk0p1

This only updates one partition but not the full device. If it is your first time flashing that jetson nano, it would not work.
Though the error log seems not as what I expected…

ok,thank you, I’ll try with sdkmanager.

hi,
The problem has been solved. Maybe there is a wireless network receiver plugged into the U port on the hardware. I tried to take it down and it was updated successfully once.Thank you for your support.